Closed Bug 349541 Opened 14 years ago Closed 12 years ago

SVG Embedded in iframe does not resize properly.

Categories

(Core :: SVG, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 373960

People

(Reporter: wfl, Unassigned)

References

Details

(Keywords: testcase)

Attachments

(4 files, 4 obsolete files)

270 bytes, application/vnd.mozilla.xul+xml
Details
258 bytes, application/vnd.mozilla.xul+xml
Details
343 bytes, application/xml
Details
258 bytes, application/vnd.mozilla.xul+xml
Details
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.4) Gecko/20060607 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.4) Gecko/20060607 Firefox/1.5.0.4

When an SVG document is loaded in an iframe, the clipping region does not appear to update when a splitter is resized.  

Reproducible: Always

Steps to Reproduce:
1. Load attached document into the browser (running at a resolution less than 1600 pixels wide).
2. Move the splitter to the right.

Actual Results:  
The region that should have updated took the background color of the iframe.

Expected Results:  
The region should have rendered the right side of a red rectangle.
Attached file Testcase (obsolete) —
Version: Trunk → 1.8 Branch
Attachment #234793 - Attachment is obsolete: true
Attached file Iframe source
Looks like the attachment still needs a bit of work to run as intended.
To trigger _properly_:
1. Download attachment 234800 [details] locally as test.xul (or whatever).
2. Download attachment 234801 [details] locally as test2.xul (must be test2.xul).
3. Open file from step 1 in browser.
4. Move the splitter to the right.
5. Note that context clicks work in the non-clipped area and do not work in the area where the rectangle should be drawn.
Attachment #234799 - Attachment is obsolete: true
Attached file live testcase
nsSVGOuterSVGFrame::Reflow isn't being called.
Is this a Linux only problem, I can't seem to reproduce this on windows.
Is this still an issue on trunk? Or only a problem on branch?
Keywords: testcase
Attachment #234800 - Attachment is obsolete: true
This is an issue only on 1.8, and I can reproduce it on Windows.

The fact that the context menu clicks don't work would seem to indicate that the XUL iframe itself isn't being resized (which would explain why nsSVGOuterSVGFrame::Reflow isn't being called).

Since this works on trunk and we're fairly close to a Firefox 3 release, I don't see this being fixed for 1.8. It would be nice to have this in an automated test though.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Flags: in-testsuite?
Resolution: --- → WONTFIX
In trunk, it's even worse.  The lefthand side of the pane doesn't even show the embedded SVG, and context menu on the left side doesn't work at all.  I would try to reproduce it on Windows, but the only machine I can access at the moment is through Terminal Services, and the only thing that renders at all is the titlebar of the window.  So I don't know if it works in Windows at 24 or 32 bpp or whatever.
Version: 1.8 Branch → Trunk
Sorry, earlier I was running a build with patches in it by mistake. This should be fixed for real when bug 294086 is fixed.
Status: RESOLVED → UNCONFIRMED
Depends on: 294086
Resolution: WONTFIX → ---
According to Neil (in bug 373960 comment 3) XUL box frames ignore percentages on their children. The one way around this that I know about is to put flex="1" on the <svg> tag. With that attribute added, the tests here work in trunk builds.
Attachment #289783 - Attachment is obsolete: true
It seems that putting flex="1" on the <svg> gets things working in Firefox 2 also, so I guess this bug condenses to "Percentage width/height on <svg> in XUL doesn't work". That's bug 373960. Since that bug is more focused on the issue, I'll mark this bug a duplicate of that bug.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 373960
You need to log in before you can comment on or make changes to this bug.