The special character in the url is interperet wrong

RESOLVED DUPLICATE of bug 261929

Status

()

RESOLVED DUPLICATE of bug 261929
13 years ago
13 years ago

People

(Reporter: eirik, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

The special character å is interperet as :
"%E5" --> http://my.opera.com/tungtr%E5dd/albums/
when is should have been interpered as:
%C3%A5 --> http://my.opera.com/tungtr%C3%A5dd/albums/

Reproducible: Always

Steps to Reproduce:
1. Enter http://my.opera.com/tungtrådd/albums/ in location bar and press enter
2. 
3. 

Actual Results:  
the location is rendered as "http://my.opera.com/tungtr%E5dd/albums/" when it should have been renderes as "http://my.opera.com/tungtr%C3%A5dd/albums/"

Expected Results:  
The page displayed in brower is the wrong one. Usually a "404 Not Found"

The software should have interpered the special character correct

Comment 1

13 years ago
WFM on trunk:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060821 Minefield/3.0a1
Fixed twice over on the trunk, but unfortunately it's not going to make 2.0

*** This bug has been marked as a duplicate of 261929 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.