Find toolbar automatically finding when opening a new window and will not copy/paste or cancel.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
12 years ago
9 years ago

People

(Reporter: god.dreams, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME?, URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

Usually when a second window is opened, finder will automatically invoke and will not cancel. I've finally found a way around it by copying text from outside firefox and pasteing it in will 'fix' it, but it seems a rather jury-rigged fix.

Reproducible: Sometimes

Steps to Reproduce:
1.Open firefox.
2.CTRL-N (or command-N) to open new window (google is my homepage)
3.Type.
Actual Results:  
Opening a new window still created the same result. Multiple new windows produce the same effect. It happens periodically on both my Windows XP machine and my Mac OS X iBook.

Expected Results:  
It should let me type in the google search/wherever without forcing it to find. 

This is *NOT* activated by '/' or '`' or '''. It is automatically doing this, and I have set the about:config to turn autofind off, and it still occurs. User.js is not created.

Comment 1

12 years ago
I've seen what I think is the same problem.  I have a bookmark to google.  When I open it in the current tab then typing will enter text in the search box.  But when I open that bookmark in a new tab then typing starts finding.  The problem is not with the find toolbar.  The problem is that when I open the bookmark in a new tab the keyboard focus is not in the search field (no caret in the search text box).  While when I open the bookmark in the current tab the keyboard focus is in the search field (caret is present in the search text box).  

So to work around the problem I have to manually set the focus to the search field by clicking in it or tabbing to it with the tab key.    

Is the caret present in the search box when this problem occurs?

Comment 2

12 years ago
Hmmm now I think the problem I see is not the same.  If I open my bookmark in a new window the search field is focused and typing does enter text into search field.  Also there is no problem when opening my bookmark in a new foreground tab.  The problem I see is only with background tabs.

But I'll still ask if you see a caret in the search field when you see your problem?
(Reporter)

Comment 3

12 years ago
Yeah - the caret is in the search field, and it occurs with new window fields. I can use keyboard shortcuts to open a new page, but it still will not let me type (automatically opens find). I've tried ESC - which closes the finder, until I type.

I cannot copy any text in the window (if I go to the BBC/CNN/BoingBoing), but if I copy some text - like from a text editor/terminal window and paste it in, it fixes the problem.
It seems to me that you're seeing bug 339465 here, not?
Blocks: 320465
(Reporter)

Comment 5

12 years ago
It is similar to 339465, however:

1. It happens outside of google.
2. about:config - accessibility.typeaheadfind is false
3. The Find Bar will popup just like 339465, but you will *only* be typing in the finder bar, and only the finder bar. Closing the finder bar (or hitting ESC) will make the finder disappear, but the moment you type again it will bring up the finder bar again.
4. Minimizing/Maximizing has had no affect for me.

Comment 6

12 years ago
Does this still happen with the latest Firefox builds?

If not, please close the bug as WORKSFORME.

Thanks!
OS: Other → All
Whiteboard: CLOSEME 08/14, DUPEME?
Whiteboard: CLOSEME 08/14, DUPEME? → DUPEME?
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit

Updated

9 years ago
Summary: Find toolbar automatically finding when opening a new window and will nto copy/paste or cancel. → Find toolbar automatically finding when opening a new window and will not copy/paste or cancel.
(Reporter)

Comment 7

9 years ago
Latest builds have resolved the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.