Tag test cases by platform

RESOLVED WONTFIX

Status

Webtools Graveyard
Litmus
P3
enhancement
RESOLVED WONTFIX
12 years ago
2 years ago

People

(Reporter: Fallen, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: 20060822

The user supplies what platform he is testing on. Give the possibility to tag certain testcases for a specific platform.

For example installer test cases in sunbird: Only windows has an installer. 

1. Create a testcase that tells the user to use the installer. 
2. Tag it as windows only
3. A user that is running a test on linux dosen't see the test case.

Reproducible: Always

Comment 1

11 years ago
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

11 years ago
One example where this would be useful is:

http://litmus.mozilla.org/show_test.cgi?id=2469

Note: I'm not saying that's grounds to implement it.
I tihnk this would be a great enhancement, especially in light of the platform-specific issues going with Leopard and Vista. 

Updated

11 years ago
Duplicate of this bug: 390826

Updated

10 years ago
Priority: -- → P3

Updated

10 years ago
Assignee: ccooper → nobody
I think this will probably have to wait for the final tagging implementation. It would be non trivial to do this unless web dev has cycles to do the work.

Comment 6

5 years ago
Litmus is being decommissioned in bug 802674. 

Visit https://moztrap.mozilla.org for your testing needs.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.