cairo crash [@ _cairo_clip_init_deep_copy()]

RESOLVED FIXED

Status

()

Core
Graphics
--
critical
RESOLVED FIXED
12 years ago
7 years ago

People

(Reporter: Alex Fritze, Assigned: vlad)

Tracking

({crash})

Trunk
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
I'm experiencing a crash in _cairo_clip_init_deep_copy() in a xulrunner app that draws SVG onto a custom widget. I don't have a simple testcase unfortunately.

The problem is that _cairo_clip_init_deep_copy() tries to copy the wrong surface (clip->surface is null):

Index: cairo-clip.c
===================================================================
--- cairo-clip.c        (revision 13297)
+++ cairo-clip.c        (working copy)
@@ -525,7 +525,7 @@
         }

         if (other->surface) {
-            _cairo_surface_clone_similar (target, clip->surface, &clip->surface);
+            _cairo_surface_clone_similar (target, other->surface, &clip->surface);
             clip->surface_rect = other->surface_rect;
         }

Comment 1

12 years ago
Hrm... maybe this should be filed upstream?
Severity: normal → critical
Keywords: crash
Summary: cairo crash in _cairo_clip_init_deep_copy() → cairo crash [@ _cairo_clip_init_deep_copy()]

Comment 2

12 years ago
please file this upstream. bugzilla.freedesktop.org
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
Er, no idea why this was closed as invalid, because it's still a valid crash.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Created attachment 245297 [details] [diff] [review]
cairo crash fix

Patch from upstream-ish; we'll take this as a band-aid before we upgrade our cairo to the trunk.
Assignee: nobody → vladimir
Status: REOPENED → ASSIGNED
Attachment #245297 - Flags: review+
*** Bug 357254 has been marked as a duplicate of this bug. ***
Checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
Crash Signature: [@ _cairo_clip_init_deep_copy()]
You need to log in before you can comment on or make changes to this bug.