Last Comment Bug 349906 - Don't depend on PangoXft
: Don't depend on PangoXft
Status: RESOLVED FIXED
: fixed1.8.1.8
Product: Core Graveyard
Classification: Graveyard
Component: GFX: Gtk (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Behdad Esfahbod
:
Mentors:
Depends on:
Blocks: 292847
  Show dependency treegraph
 
Reported: 2006-08-23 11:55 PDT by Behdad Esfahbod
Modified: 2009-01-22 10:17 PST (History)
5 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Mentioned patch (1.55 KB, patch)
2006-08-23 11:56 PDT, Behdad Esfahbod
no flags Details | Diff | Splinter Review
Updated patch (1.37 KB, patch)
2006-08-24 19:06 PDT, Behdad Esfahbod
jshin1987: review+
rbs: superreview+
dveditz: approval1.8.1.8+
Details | Diff | Splinter Review

Description Behdad Esfahbod 2006-08-23 11:55:40 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.13) Gecko/20060501 Epiphany/2.14
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.13) Gecko/20060501 Epiphany/2.14

Currently the Pango font backend depends on Gtk+ using the PangoXft backend.  Which is wrong for Gtk+ 2.8.  Attaching fix.

Reproducible: Always
Comment 1 Behdad Esfahbod 2006-08-23 11:56:15 PDT
Created attachment 235103 [details] [diff] [review]
Mentioned patch
Comment 2 rbs 2006-08-23 20:18:27 PDT
Comment on attachment 235103 [details] [diff] [review]
Mentioned patch

That code hasn't evolved much since blizzard's initial check-in. I will sr if jshin is happy with the patch.
http://bonsai.mozilla.org/cvslog.cgi?file=mozilla/gfx/src/gtk/mozilla-decoder.cpp&rev=HEAD&mark=1.3
Comment 3 rbs 2006-08-24 18:47:55 PDT
Note to self. Undo the debugging #define

 #undef DEBUG_CUSTOM_ENCODER
+#define DEBUG_CUSTOM_ENCODER 1
Comment 4 Behdad Esfahbod 2006-08-24 19:06:12 PDT
Created attachment 235350 [details] [diff] [review]
Updated patch

Removed the debugging statement.
Comment 5 Jungshik Shin 2006-08-27 22:11:21 PDT
Comment on attachment 235350 [details] [diff] [review]
Updated patch

r=jshin
Comment 6 rbs 2006-08-29 00:18:04 PDT
Comment on attachment 235350 [details] [diff] [review]
Updated patch

sr=rbs, I will check this in quickly.
Comment 7 rbs 2006-08-29 10:23:27 PDT
Checked in.
Comment 8 Walter Meinl 2006-08-30 08:33:52 PDT
(In reply to comment #7)
> Checked in.
> 

In bug 338446 we took care that configure(.in) checks for the presence of pangoxft in order to pull it in, as pangoxft automatically pulled by gtk+ 2.8. The only reason was the dependency of gfx/src/gtk/mozilla-decoder.cpp on pangoxft. Now, we could reverse the part of the patch https://bugzilla.mozilla.org/attachment.cgi?id=227071 concerning configure.in (but not gfx/src/gtk/Makefile.in) as pangoxft isn't needed anymore in case using default-toolkit=gtk2.
Interestingly, yesterday for the cairo-gtk2 toolkit a patch for bug 334064 was checked in that brings in more pangoxft dependencies.
Comment 9 Karl Tomlinson (:karlt) 2007-09-16 17:54:49 PDT
Comment on attachment 235350 [details] [diff] [review]
Updated patch

Branch approval requested for same reasons as:

https://bugzilla.mozilla.org/show_bug.cgi?id=349904#c6
Comment 10 Daniel Veditz [:dveditz] 2007-09-28 16:34:32 PDT
Comment on attachment 235350 [details] [diff] [review]
Updated patch

approved for 1.8.1.8, a=dveditz for release-drivers
Comment 11 Martijn Wargers [:mwargers] (not working for Mozilla) 2007-10-02 13:35:15 PDT
Checking in mozilla-decoder.cpp;
/cvsroot/mozilla/gfx/src/gtk/Attic/mozilla-decoder.cpp,v  <--  mozilla-decoder.c
pp
new revision: 1.3.20.1; previous revision: 1.3
done

Checked into the 1.8.1 branch.

Note You need to log in before you can comment on or make changes to this bug.