document.createAttribute doesn't throw exception

VERIFIED DUPLICATE of bug 16603

Status

()

Core
DOM
P3
major
VERIFIED DUPLICATE of bug 16603
18 years ago
17 years ago

People

(Reporter: ckritzer (gone), Assigned: jst)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Overview:  When using:

     document.createAttribute(" € !≈ ∞ ∴ foo");

no exception is being thrown.

Actual Results:  No exception is being thrown.

Expected Results:  The exception INVALID_CHARACTER_ERR should be thrown.

Platforms Bug Appears On:
- Linux6 2000-04-06-17-M15 Commercial build
- Win98 2000-04-06-17-M15 Commercial build
- MacOS9 2000-04-06-15-M15 Commercial build
(Reporter)

Comment 1

18 years ago
Created attachment 7339 [details]
testcase showing no exception being thrown
(Reporter)

Comment 2

18 years ago
Changed self to qacontact
QA Contact: gerardok → ckritzer
(Assignee)

Comment 3

18 years ago
This problem is coverd by bug #16603, marking as duplicate.

*** This bug has been marked as a duplicate of 16603 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.