need to get talkback symbols uploaded for Fx2b2 candidates

VERIFIED FIXED in mozilla1.8.1beta2

Status

()

Core
Build Config
--
blocker
VERIFIED FIXED
12 years ago
12 years ago

People

(Reporter: dbaron, Assigned: preed)

Tracking

({verified1.8.1})

1.8 Branch
mozilla1.8.1beta2
x86
Windows XP
verified1.8.1
Points:
---
Bug Flags:
blocking1.8.1 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
Bug 349577 prevented the talkback symbols from being uploaded for the Fx2 beta2 candidates.  The symbols need to be uploaded so that we have working talkback for the release.  (I just submitted a crash report and it came out as all "firefox.exe".)
(Reporter)

Updated

12 years ago
Flags: blocking1.8.1?
(Assignee)

Comment 1

12 years ago
I did this last week, but it uploaded the symbols to hal (because that's what the scripts still currently do).

I'm told that the symbols should've been mirrored over to the new talkback server by now, though.
Assignee: nobody → preed
(Assignee)

Comment 2

12 years ago
Per IRC, over to Jay to let us know if the rsync process from hal to spike, is it, worked.
Assignee: preed → jay
Status: NEW → ASSIGNED
Flags: blocking1.8.1? → blocking1.8.1+

Comment 3

12 years ago
Reassigning to Preed.

According to http://wiki.mozilla.org/Firefox:2.0_QA_Activities#Smoke_tests_-_Aug_21.2C_2006, I am assuming the final build ids for FF2b2 are:

Windows: 2006082101
MacOS X: 2006082115 (due to respin)
Linux:   2006082104

If that is the case, NONE of those symbols are on HAL (and therefore were never rsync'd to Spike).

Here is what I see on HAL:
Win32:
total 0
drwxrwxrwx+ 7 symbols None 0 Aug 25 06:06 .
drwxrwxrwx+ 2 symbols None 0 Aug 25 06:04 2006082504
drwxrwxrwx+ 2 symbols None 0 Aug 24 05:13 2006082403
drwxrwxrwx+ 2 symbols None 0 Aug 23 05:17 2006082303
drwxrwxrwx+ 5 symbols None 0 Aug 22 05:23 ..
drwxrwxrwx+ 2 symbols None 0 Aug 22 05:22 2006082203
drwxrwxrwx+ 2 symbols None 0 Aug 21 05:38 2006082103

MacOSX:
total 0
drwxrwxrwx+ 7 symbols None 0 Aug 25 05:07 .
drwxrwxrwx+ 2 symbols None 0 Aug 25 05:06 2006082503
drwxrwxrwx+ 2 symbols None 0 Aug 24 04:56 2006082403
drwxrwxrwx+ 2 symbols None 0 Aug 23 08:15 2006082306
drwxrwxrwx+ 5 symbols None 0 Aug 22 05:23 ..
drwxrwxrwx+ 2 symbols None 0 Aug 22 04:45 2006082203
drwxrwxrwx+ 2 symbols None 0 Aug 21 03:15 2006082101

LinuxIntel:
total 0
drwxrwxrwx+ 7 symbols None 0 Aug 25 04:55 .
drwxrwxrwx+ 2 symbols None 0 Aug 25 04:53 2006082504
drwxrwxrwx+ 2 symbols None 0 Aug 24 04:55 2006082404
drwxrwxrwx+ 2 symbols None 0 Aug 23 05:22 2006082304
drwxrwxrwx+ 5 symbols None 0 Aug 22 05:23 ..
drwxrwxrwx+ 2 symbols None 0 Aug 22 05:22 2006082204
drwxrwxrwx+ 2 symbols None 0 Aug 21 02:20 2006082101

------------

A couple of the candidate dirs are on Spike, but they only contain 1 symbol file, probably the one that was copy originally just after HAL ran out of diskspace.

Here is what I see on Spike:
Administrator@spike /g/symbols/Mozillaorg/Firefox2
$ ll Win32/ | grep 2006082
drwxr-xr-x+   2 Administrator None   0 Aug 25 06:04 2006082504/
drwxr-xr-x+   2 Administrator None   0 Aug 24 05:13 2006082403/
drwxr-xr-x+   2 Administrator None   0 Aug 23 05:17 2006082303/
drwxr-xr-x+   2 Administrator None   0 Aug 22 05:22 2006082203/
drwxr-xr-x+   2 Administrator None   0 Aug 21 05:38 2006082103/
drwxr-xr-x+   2 Administrator None   0 Aug 21 04:13 2006082101/
drwxr-xr-x+   2 Administrator None   0 Aug 20 05:58 2006082004/

Administrator@spike /g/symbols/Mozillaorg/Firefox2
$ ll MacOSX/ | grep 2006082
drwxr-xr-x+   2 Administrator None   0 Aug 25 05:06 2006082503/
drwxr-xr-x+   2 Administrator None   0 Aug 24 04:56 2006082403/
drwxr-xr-x+   2 Administrator None   0 Aug 23 08:15 2006082306/
drwxr-xr-x+   2 Administrator None   0 Aug 22 04:45 2006082203/
drwxr-xr-x+   2 Administrator None   0 Aug 21 04:53 2006082103/
drwxr-xr-x+   2 Administrator None   0 Aug 21 03:15 2006082101/
drwxr-xr-x+   2 Administrator None   0 Aug 20 04:35 2006082003/
Administrator@spike /g/symbols/Mozillaorg/Firefox2
$ ll LinuxIntel/ | grep 2006082
drwxr-xr-x+   2 Administrator None   0 Aug 25 04:53 2006082504/
drwxr-xr-x+   2 Administrator None   0 Aug 24 04:55 2006082404/
drwxr-xr-x+   2 Administrator None   0 Aug 23 05:22 2006082304/
drwxr-xr-x+   2 Administrator None   0 Aug 22 05:22 2006082204/
drwxr-xr-x+   2 Administrator None   0 Aug 21 05:09 2006082104/
drwxr-xr-x+   2 Administrator None   0 Aug 21 02:20 2006082101/
drwxr-xr-x+   2 Administrator None   0 Aug 20 05:04 2006082004/

And the candidate build dirs on Spike:
Administrator@spike /g/symbols/Mozillaorg/Firefox2
$ ll Win32/2006082101/
total 0
drwxr-xr-x+ 282 Administrator None 0 Aug 25 06:06 ../
drwxr-xr-x+   2 Administrator None 0 Aug 21 04:13 ./
-rw-r--r--    1 Administrator None 0 Aug 21 04:12 AccessibleMarshal.pdb

Administrator@spike /g/symbols/Mozillaorg/Firefox2
$ ll MacOSX/2006082115/
ls: MacOSX/2006082115/: No such file or directory

Administrator@spike /g/symbols/Mozillaorg/Firefox2
$ ll LinuxIntel/2006082104/
total 0
drwxr-xr-x+ 245 Administrator None 0 Aug 25 04:55 ../
-rw-r--r--    1 Administrator None 0 Aug 21 05:11 firefox-bin.elf
drwxr-xr-x+   2 Administrator None 0 Aug 21 05:09 ./


So basically, if the builds I noted above are indeed the final Talkback build ids for the candidates we plan to ship, someone needs to push them to HAL again... and then wait a couple of hours before checking Spike.

I think the symbols upload process should be owned by the build team, so if you guys can get access to both HAL and Spike, that will be great.  I'm sure IT can set you up with ssh access for the Administrator user on both machines.

Here is what I see on Spike:

Assignee: jay → preed
Status: ASSIGNED → NEW
Per Jay's request on IRC, I can confirm the Windows and Mac build IDs in 
Comment 3 are correct.  These have been the builds we have smoketested and we are running the FFTs against. Could use some help with confirming Linux if someone has it handy.
(Assignee)

Comment 5

12 years ago
(In reply to comment #3)
> Reassigning to Preed.
> 
> According to
> http://wiki.mozilla.org/Firefox:2.0_QA_Activities#Smoke_tests_-_Aug_21.2C_2006,
> I am assuming the final build ids for FF2b2 are:
> 
> Windows: 2006082101
> MacOS X: 2006082115 (due to respin)
> Linux:   2006082104

Almost. The Linux Build ID should be: 2006082101 (they were all kicked off at the same time, except for Mac, due to the respin).

I looked through the bash_history files for all three platforms; they show the upload-symbols.sh I ran last week, but I'll run them again:

For Linux:

[cltbld@prometheus-vm 2006082101]$ date
Fri Aug 25 14:43:10 PDT 2006
[cltbld@prometheus-vm 2006082101]$ hostname
prometheus-vm.build.mozilla.org
[cltbld@prometheus-vm 2006082101]$ pwd
/builds/tinderbox/Fx-Mozilla1.8-release/Linux_2.4.21-27.0.4.EL_Depend/2006082101
[cltbld@prometheus-vm 2006082101]$ ./upload-symbols.sh 
Making /home/symbols/symbols/MozillaOrg/Firefox2/LinuxIntel on the remote host...
Transferring symbols...
bind: Address already in use
channel_setup_fwd_listener: cannot listen to port: 2222
Could not request local forwarding.
2006082101.tar.bz2                            100%   36MB   1.9MB/s   00:18    
Unpacking symbols on remote host...
bind: Address already in use
channel_setup_fwd_listener: cannot listen to port: 2222
Could not request local forwarding.
2006082101/
2006082101/firefox-bin.elf
2006082101/libfreebl3.so
2006082101/libmozjs.so
2006082101/libnspr4.so
2006082101/libnss3.so
2006082101/libnssckbi.so
2006082101/libplc4.so
2006082101/libplds4.so
2006082101/libsmime3.so
2006082101/libsoftokn3.so
2006082101/libssl3.so
2006082101/libxpcom_compat.so
2006082101/libxpcom_core.so
2006082101/libxpcom.so
2006082101/libxpistub.so
2006082101/libimgicon.so
2006082101/libjar50.so
2006082101/libjsd.so
2006082101/libmozgnome.so
2006082101/libmyspell.so
2006082101/libnkgnomevfs.so
2006082101/libspellchecker.so
2006082101/libxpinstall.so
removed `2006082101.tar.bz2'
Symbol transfer completed.
[cltbld@prometheus-vm 2006082101]$ 


For Win32:

cltbld@pacifica-vm /cygdrive/c/builds/tinderbox/Fx-Mozilla1.8-release/WINNT_5.2_
Depend/2006082101
$ date
Fri Aug 25 14:47:32 PDT 2006

cltbld@pacifica-vm /cygdrive/c/builds/tinderbox/Fx-Mozilla1.8-release/WINNT_5.2_
Depend/2006082101
$ hostname
pacifica-vm

cltbld@pacifica-vm /cygdrive/c/builds/tinderbox/Fx-Mozilla1.8-release/WINNT_5.2_
Depend/2006082101
$ pwd
/cygdrive/c/builds/tinderbox/Fx-Mozilla1.8-release/WINNT_5.2_Depend/2006082101

cltbld@pacifica-vm /cygdrive/c/builds/tinderbox/Fx-Mozilla1.8-release/WINNT_5.2_
Depend/2006082101
$ ./upload-symbols.sh
Making /home/symbols/symbols/MozillaOrg/Firefox2/Win32 on the remote host...
Transferring symbols...
2006082101.tar.bz2                            100%   23MB   1.4MB/s   00:16
Unpacking symbols on remote host...
2006082101/
2006082101/AccessibleMarshal.pdb
2006082101/ds32.pdb
2006082101/firefox.pdb
2006082101/freebl3.pdb
2006082101/GetShortPathName.pdb
2006082101/jar50.pdb
2006082101/js3250.pdb
2006082101/jsd3250.pdb
2006082101/mozctl.pdb
2006082101/mozctlx.pdb
2006082101/myspell.pdb
2006082101/npmozax.pdb
2006082101/npnul32.pdb
2006082101/nsinstall.pdb
2006082101/nspr4.pdb
2006082101/nss3.pdb
2006082101/nssckbi.pdb
2006082101/nsztool.pdb
2006082101/plc4.pdb
2006082101/plds4.pdb
2006082101/regxpcom.pdb
2006082101/ren8dot3.pdb
2006082101/schemval.pdb
2006082101/setup.pdb
2006082101/setuprsc.pdb
2006082101/smime3.pdb
2006082101/softokn3.pdb
2006082101/spellchk.pdb
2006082101/ssl3.pdb
2006082101/uninstall.pdb
2006082101/updater.pdb
2006082101/winEmbed.pdb
2006082101/xforms.pdb
2006082101/xpcom.pdb
2006082101/xpcom_compat.pdb
2006082101/xpcom_core.pdb
2006082101/xpcshell.pdb
2006082101/xpicleanup.pdb
2006082101/xpidl.pdb
2006082101/xpinstal.pdb
2006082101/xpistub.pdb
2006082101/xpt_dump.pdb
2006082101/xpt_link.pdb
removed `2006082101.tar.bz2'
Symbol transfer completed.

cltbld@pacifica-vm /cygdrive/c/builds/tinderbox/Fx-Mozilla1.8-release/WINNT_5.2_
Depend/2006082101

For mac:

bm-xserve02:/builds/tinderbox/Fx-Mozilla1.8-release/Darwin_8.7.0_Depend/2006082115 cltbld$ date
Fri Aug 25 15:05:39 PDT 2006
bm-xserve02:/builds/tinderbox/Fx-Mozilla1.8-release/Darwin_8.7.0_Depend/2006082115 cltbld$ hostname
bm-xserve02.mozilla.org
bm-xserve02:/builds/tinderbox/Fx-Mozilla1.8-release/Darwin_8.7.0_Depend/2006082115 cltbld$ pwd
/builds/tinderbox/Fx-Mozilla1.8-release/Darwin_8.7.0_Depend/2006082115
bm-xserve02:/builds/tinderbox/Fx-Mozilla1.8-release/Darwin_8.7.0_Depend/2006082115 cltbld$ ./upload-symbols.sh 
Making /home/symbols/symbols/MozillaOrg/Firefox2/MacOSX on the remote host...
reverse mapping checking getaddrinfo for surf.sj.mozilla.org failed - POSSIBLE BREAKIN ATTEMPT!
Transferring symbols...
reverse mapping checking getaddrinfo for surf.sj.mozilla.org failed - POSSIBLE BREAKIN ATTEMPT!
bind: Address already in use
channel_setup_fwd_listener: cannot listen to port: 2222
Could not request local forwarding.
2006082115.tar.bz2                            100%   68MB   4.0MB/s   00:17    
Unpacking symbols on remote host...
reverse mapping checking getaddrinfo for surf.sj.mozilla.org failed - POSSIBLE BREAKIN ATTEMPT!
bind: Address already in use
channel_setup_fwd_listener: cannot listen to port: 2222
Could not request local forwarding.
2006082115/
2006082115/firefox-bin
2006082115/libfreebl3.dylib
2006082115/libjsd.dylib
2006082115/libmozjs.dylib
2006082115/libmyspell.dylib
2006082115/libnspr4.dylib
2006082115/libnss3.dylib
2006082115/libnssckbi.dylib
2006082115/libplc4.dylib
2006082115/libplds4.dylib
2006082115/libsmime3.dylib
2006082115/libsoftokn3.dylib
2006082115/libspellchecker.dylib
2006082115/libssl3.dylib
2006082115/libxpcom.dylib
2006082115/libxpcom_compat.dylib
2006082115/libxpcom_core.dylib
2006082115/libxpinstall.dylib
2006082115/libxpistub.dylib
removed `2006082115.tar.bz2'
Symbol transfer completed.
bm-xserve02:/builds/tinderbox/Fx-Mozilla1.8-release/Darwin_8.7.0_Depend/2006082115 cltbld$

Let's see if it takes this time.
I just installed the Linux build in the QA lab and it does have the same build ID as Windows. I will investigate what Tracy tested for the smoketest.
(Reporter)

Comment 7

12 years ago
I'm getting good symbols across 3 platforms now:

MozillaOrgFirefox2Win322006082101 ==> TB22514961
MozillaOrgFirefox2LinuxIntel2006082101 ==> TB22515374
MozillaOrgFirefox2MacOSX2006082115 ==> TB22515426
(Assignee)

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Can we get this marked fixed/verified1.8.1?

Comment 9

12 years ago
ff2b2 winxp TB22633862H, linux TB22634170Z, I can't seem to find mac crashers if someone else would like to find them and check if they have symbols.

Comment 10

12 years ago
According to http://talkback-public.mozilla.org/reports/firefox/FF2x/FF2x-topcrashers.html, we have been getting good data for all 3 platforms since Preed pushed the symbols.  Marking v.fixed.

I will setup Talkback reports for "FF2b2" as soon as we're ready to ship and these builds are indeed going to go live.
Status: RESOLVED → VERIFIED
Keywords: verified1.8.1
You need to log in before you can comment on or make changes to this bug.