Provide a summary page similar to Jira's

RESOLVED DUPLICATE of bug 201756

Status

()

Bugzilla
Reporting/Charting
--
enhancement
RESOLVED DUPLICATE of bug 201756
11 years ago
11 years ago

People

(Reporter: Jimisola Laursen, Assigned: gerv)

Tracking

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

Jira has a VERY useful summary page which easily gives the user a quick glance/view of the project such as:

 - General project information (project lead, url, description etc)
 - components and versions (with bug count for each component/version)
 - reports, e.g.:
    Created vs Resolved Issues Report
    Resolution Time Report
    Average Age Report
    Recently Created Issues Report
    Pie Chart Report
    Time Tracking Report
    User Workload Report
    Single Level Group By Report
    Version Workload Report
 - Preset filter/queries:
  - All
  - Outstanding
  - Unscheduled
  - Assigned to me
  - Reported by me
  - Resolved recently
  - Added recently
  - Updated recently
  - Most important 
 - Project Summary: open and closed issues
 - list of open issues by severity, assignee (priority would be interesting as well)
 . See for example: http://jira.codehaus.org/browse/MDEP

I really miss out on this kind of information in Bugzilla and I believe that it would be of great value to the Bugzilla community.

Reproducible: Always

Comment 1

11 years ago
Jira is a commercial product, and is thus under a copyright, not an open-source license. We can't use it for inspiration, or we may be creating a "derived work" and be legally liable under copyright law.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

11 years ago
So, you are saying that just because Jira has a summary page Bugzilla can never have one? That sounds very odd to me. It's not an invention and doesn't have a patent.

People look at other products all the time and to get ideas etc. I am not talking about copying there xhtml/css source code.
(Assignee)

Comment 3

11 years ago
Max is mistaken. Copyright protects particular expressions of ideas - in this case, the Jira source code. As long as we don't look at that, we can't have any problems under copyright law.

Ideas themselves are covered by patent law. If the company making Jira has a patent on their front page style, we'd be in difficulty. Otherwise, fixing this bug is entirely legal.

[Of course, that says nothing about whether it's a good idea or not.]

Gerv
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
(Reporter)

Comment 4

11 years ago
Gervase, I think that Jira's summary page is one of its BIG pros on Bugzilla.
It gives developers, project lead and users an easy way to see project status.

Breakup of open issues/bugs on targets, priorities, severity and assignee gives a fast and good overview of the project status.

Comment 5

11 years ago
(In reply to comment #3)
> Max is mistaken. Copyright protects particular expressions of ideas - in this
> case, the Jira source code. As long as we don't look at that, we can't have any
> problems under copyright law.

  Technically, I could argue that an interface is an expression of the idea of the source code.

  But yes, for most cases, you're right. :-)

  In any case, I think we do have another bug filed similar to this one somewhere, about a summary page, or making the index page more useful.

Comment 6

11 years ago

*** This bug has been marked as a duplicate of 201756 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 7

11 years ago
Reopening since it is not a duplicate of bug #201756. The might share some underlying logic, but they are different in major areas. Please read my description carefully again and compare to bug #201756.

This enhancement request might be considered a summary report, but it is NOT weekly in any what way - it's a SNAPSHOT of the CURRENT state. Hence, it doesn't show information about what's happend in the last week - it shows the current state of bugs grouped on e.g. component, assignee, severity, status, priority etc. 

I haven't checked what's included in the patch for #201756, but in the original description of this enhancement request I've listed the information that is of initial interest (perhaps others have more to add to the list).
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 8

11 years ago
We are not going to keep one bug opened just because your description differs by one comma from another one. Even if the other bug mention "weekly", we can as well refresh it daily. If you want instant data, you have to use charts, but we are not going to query the DB everytime a user view the page (in the same way duplicates.cgi doesn't look at the DB directly).

Your request is similar to bug 201756. Let us (core developers) triage bugs.

*** This bug has been marked as a duplicate of 201756 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 9

11 years ago
Sad to hear that you don't seem to have an interest in communicating with your users in orderly fashion when they provide feedback.

I don't consider it to just differ in a comma and I find such a comment unnecessary. Weekly or daily is not the issue here, like I said I would want instant data if you then call it query, search or chart doesn't matter to me.

Why is it that you're not going to query the DB everytime a user view the page?
Do you have performance problems? Make it available for your customers/users and if there are performance issues then allow then to disable to instant option. Knowing that it works with Jira I would think that Bugzilla could solve such potential issues as well.

Comment 10

11 years ago
let's deal with realities.

https://bugzilla.mozilla.org/describecomponents.cgi?product=Core
lists 164 components.
https://bugzilla.mozilla.org/editvalues.cgi?field=priority
lists 6 priorities and lets me set 100. assume my boss made me set 100.
https://bugzilla.mozilla.org/report.cgi?x_axis_field=&y_axis_field=assigned_to&z_axis_field=&query_format=report-table&short_desc_type=allwordssubstr&short_desc=&product=Core&long_desc_type=substring&long_desc=&bug_file_loc_type=allwordssubstr&bug_file_loc=&status_whiteboard_type=allwordssubstr&status_whiteboard=&keywords_type=allwords&keywords=&emailassigned_to1=1&emailtype1=exact&email1=&emailassigned_to2=1&emailreporter2=1&emailqa_contact2=1&emailtype2=exact&email2=&bugidtype=include&bug_id=&votes=&chfieldfrom=&chfieldto=Now&chfieldvalue=&format=table&action=wrap&field0-0-0=noop&type0-0-0=noop&value0-0-0=
has 2448 row+textnode pairs. so 1224 rows and 1222 assignees (header, footer).
https://bugzilla.mozilla.org/editversions.cgi?product=Bugzilla
lists 98 row+textnode pairs. so 54 rows and 52 versions.
https://bugzilla.mozilla.org/chart.cgi
lists 48 named things. assume that this grows with time.

For simplicity assume that someone keeps all versions open, the projects I use outside of bmo do this.

Note that these numbers are all *public*. The databases I use are much *worse* on average. When I suggest that a boss asks someone to set 100, please don't think I'm joking. Although thankfully I don't currently maintain a bugzilla so I'm merely describing some other unfortunate person or a class of users unfortunate enough to encounter such bugzillas.

Please suggest *limits* on these things. i.e. clearly showing 100 components does not a summary make. Pick numbers for each thing.

Comment 11

11 years ago
reporter: out of curiosity, how many users and unique visitors do the jiras you're describing have? and how many hits per day?

I'm just curious and do not want you to draw any conclusions from my inquiry.
(Reporter)

Comment 12

11 years ago
I don't know have many to be honest, but I would think that it is quite substansial since e.g. both

 - Apache: https://issues.apache.org/jira/secure/Dashboard.jspa, and 
 - Codehaus: http://jira.codehaus.org

use Jira and Apache, especially, has a big community. Although, I don't think that Apache have migrated all their projects to Jira yet.

You need to log in before you can comment on or make changes to this bug.