Last Comment Bug 350296 - Mounted .dmg should leave Finder sidebar aliases (for Applications) visible
: Mounted .dmg should leave Finder sidebar aliases (for Applications) visible
Status: VERIFIED WONTFIX
:
Product: Camino Graveyard
Classification: Graveyard
Component: General (show other bugs)
: unspecified
: PowerPC Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-26 06:59 PDT by Jonathan Thurlow
Modified: 2006-11-07 14:03 PST (History)
7 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Current mounted disk image view (44.10 KB, image/png)
2006-08-26 07:04 PDT, Jonathan Thurlow
no flags Details
Proposed mounted disk image view (104.44 KB, image/png)
2006-08-26 07:05 PDT, Jonathan Thurlow
no flags Details

Description Jonathan Thurlow 2006-08-26 06:59:00 PDT
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; chrome://navigator/locale/navigator.properties; rv:1.9a1) Gecko/20060825 Camino/1.2+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; chrome://navigator/locale/navigator.properties; rv:1.9a1) Gecko/20060825 Camino/1.2+

When mounting the Camino disk image, there's a graphic representation to indicate you need to drag the Camino app to the Applications folder.  But there's no intuitive way to access either the Applications folder or any alias to it.

The "usual" way I presume new users access the Applications folder (based on study of 3 people) is by clicking on the Finder icon in the dock.  With the .dmg mounted, all that does is focuses the mounted dmg.  To get to the Applications folder, one either has to know about File > New Finder window, or know that the grey tictac button in the top right expands the window to show the shortcuts/aliases on the left.  Neither of which are particularly obvious to a new user.

I know there's bug 317220 and it's been decided not to put an alias inside the disk image (although most other apps seem to do it).

So how about having the default view of the mounted .dmg as having the sidebar thing (sorry I don't know the proper terms) with Applications/Documents/etc down the side, so users can see where this Applications folder is that they're meant to drag Camino into?

Reproducible: Always

Steps to Reproduce:
1. Download Camino.dmg
2. Double click it
Actual Results:  
Opens in a Finder window with grey pic at top to suggest dragging it to Applications folder

Expected Results:  
As currently done, but with sidebar visible so people can see where this Applications folder is.  

(Alternatively, rethink whether having alias inside the .dmg is really a bad idea)
Comment 1 Jonathan Thurlow 2006-08-26 07:04:11 PDT
Created attachment 235559 [details]
Current mounted disk image view
Comment 2 Jonathan Thurlow 2006-08-26 07:05:39 PDT
Created attachment 235560 [details]
Proposed mounted disk image view

Might be worth changing the grey pic to look the same as the Finder sidebar shortcut for the Applications folder
Comment 3 Samuel Sidler (old account; do not CC) 2006-08-26 08:49:44 PDT
Since we're moving to 10.3+ (which has a sidebar, where 10.2 didn't), this might be nice to have.

Mark, what do you think of this? And what is Firefox doing now and in the future?
Comment 4 Chris Lawson (gone) 2006-08-26 09:12:08 PDT
Isn't the sidebar part of the problem, in that it makes users think "OH MY GOD CAMINO HAS MY HARD DRIVE ON THEIR DISK IMAGE!!!" ? I swear there was some discussion about that a while back, and knowing some of the feedback we get, I would not be at all surprised to learn that this is the case.

cl
Comment 5 Chris Wells 2006-08-26 09:21:34 PDT
There is some discussion about this on MZ (http://forums.mozillazine.org/viewtopic.php?t=453482) that spawned this bug.  Frankly, I don't think it should be Camino's problem that users don't understand what the sidebar represents.  As I stated in the post on MZ (with regards to an Applications alias, which would be a similar change), any user who is confused and thinks that s/he has just download his/her Applications folder is likely no more or less confused by the current image at the top of the window and/or what to do with the Camino application therein.  IMHO, it is a poor excuse to avoid such a simple and convenient change.

To follow along with "quoting stupid users" -- LOOK CAMINO IS IN THIS FOLDER THAT JUST OPENED FROM MY DESKTOP, I CAN OPEN IT RIGHT AWAY!! SO EASY!!
Comment 6 Smokey Ardisson (offline for a while; not following bugs - do not email) 2006-08-26 09:33:48 PDT
That stupid sidebar looks so unprofessional, like someone just slapped files on a .dmg and didn't care how it looked.

One of the reasons Camino looks so polished is because it has a nice polished .dmg and no ill-fitting sidebar.
Comment 7 Mark Mentovai 2006-08-26 11:11:03 PDT
I think the sidebar looks like crap.

We (meaning I) originally avoided putting an alias to the Applications folder in the disk image because of the "I just downloaded my hard drive" thing, but a few other apps put an alias there now so it doesn't seem so odd to have one there.  There's also the problem that the name of the link isn't localizable, although for the English-only download of Camino, we could reasonably just call it Applications and leave it unlocalized.

Somewhere, I've got a modified version of pkg-dmg that creates arbitrary symlinks.

> IMHO, it is a poor excuse to avoid such a simple and convenient change.

Simple?  Any idea what goes into preparing the .DS_Store file?  :)

Maybe we could consider having Camino.app in the disk image alongside a small stub .pkg that copies it to the Applications folder?
Comment 8 Chris Wells 2006-08-26 11:13:40 PDT
> Simple?  Any idea what goes into preparing the .DS_Store file?  :)

No, sorry.  I suppose I could have added "seemingly" and just been wrong without sounding like an ass (:
Comment 9 Ilya Sherman 2006-09-15 01:08:25 PDT
As someone who switched to OS 10.4 recently, I can vouch that the less the user has to do to get an application installed, the less confusing it is.  When I downloaded my first disk image, I spent a good 10~15 minutes researching online how on earth Macintosh applications are installed, and there's a good chance that first program was a browser, because I quickly became not a big fan of Safari.

So, I propose at least text instructions in the disk image (at least in the English-only distro), and ideally some way to get to the applications folder from the same window.  Personally, I'm a big fan of the alias to the Applications folder.

As far as the sidebar making the disk image look unpolished: when there is neither alias nor sidebar, I show the sidebar anyway, so that I don't have to drag to another window.  This isn't as big a with a real mouse, but with a trackpad minimum distance is crucial.
Comment 10 Chris Lawson (gone) 2006-10-17 21:20:19 PDT
We're definitely NOT going to put the sidebar in the dimmidge.

Mark, wanna file a new bug for comment 7 (possibly incorporating part of comment 9 on the English distro as well)?

cl
Comment 11 Mark Mentovai 2006-10-19 10:57:21 PDT
Sure.
Comment 12 Ilya Sherman 2006-11-07 14:03:00 PST
Pardon the spam, but what is the # for the new bug?  I can't seem to find it by searching.

Note You need to log in before you can comment on or make changes to this bug.