double opening tabs with target='_blank' follow by button

RESOLVED DUPLICATE of bug 346401

Status

()

defect
RESOLVED DUPLICATE of bug 346401
13 years ago
9 years ago

People

(Reporter: d.beauvisage, Unassigned)

Tracking

({regression, testcase})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Reporter

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

The following code : <a href='http://www.mozilla-europe.org' target='blank'><input type='button' value='Mozilla'></a> create a button witch open two tabs on a click

Reproducible: Always



Expected Results:  
opening one tab
WFM, Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.8.1b2) Gecko/2006082101 Firefox/2.0b2
Posted file Testcase
Ouch, actually it does, but only if target="_blank", and not with target="blank" like in comment 0.
Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Reporter

Comment 4

13 years ago
(In reply to comment #3)
> Confirming.
> 
The underscore misses in my comment but not in the summary. I tried with it, then without and the result is the same. 
I see this too, with
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1b2) Gecko/20060827 BonEcho/2.0b2
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
New profile in both cases.
Keywords: testcase
OS: Linux → All
Hardware: PC → All
Version: unspecified → Trunk
Likely a regression from bug 289940.
Assignee: nobody → events
Blocks: 289940
Component: Tabbed Browser → DOM: Events
Product: Firefox → Core
QA Contact: tabbed.browser → ian
This bug was observed with <input type=submit/reset> too, in addition to <input type=button>. (When Win32 build, started to occur with trunk 2005/04/29-07 build)
In addition to <input type=submit/button/reset>, same problem(double scheduling of <A HREF>) started to occur on <BUTTON type=submit/button/reset> with Fx 3 (Bug 384364).
Bug 384364 is DUP of this bug?

Note: As described in Bug 384364, this bug causes double HTTP GET to URL specified in <a href>. It'll sometimes cause problem in server side PHP/JSP/ASP applications, if application don't have sufficient protection on "double GET/POST".
Blocks: 384364
Problem of Bug 127903 doesn't occur with Fx 3 & Fx trunk, so both of "A HREF" and "FORM ACTION" are invoked when both "LINK in FORM" case and "FORM in LINK" case. And, when FORM is used, scheduling of load for ACTION/HREF can be postponed by alert() in onSubmit handler of FORM. Attached test case is to see when ACTION/HREF is scheduled.
See "Test Result" section in attached HTML for my test result.

Following is trace data for first schedule of "A HREF". 
> 18(194 msec) : (*1) HREF of link_34, load_count=1 (Alert is issued)
Following is trace data for second schedule of "A HREF". 
> 27(18383 msec) : (*3) HREF of link_34, load_count=3 (Alert is issued)

First schedule of "A HREF" looks to be a result of ususal link click.
Second schedule of "A HREF" seems to be a result of propagation of "Default Action" by click of "INPUT type=submit".
It looks that "BUTTON/INPUT type=button/reset" case is similar to "retrurn false case by onSubmit handler of FORM".
Test procedure:
(0)Enable JavaScript
(1)Load the test HTML
(2)Check "Issue alert in onSubmit", "Issue alert in ACTION", "Issue alert in HREF"
(3)Click button
Before execute other case, please click "Clear message/Re-initialize data" button.
Assignee: events → nobody
QA Contact: ian → events

Updated

9 years ago
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 346401
You need to log in before you can comment on or make changes to this bug.