if search bar memory not cleared searching on wikipedia then scrolling down the page creates visual artifact

RESOLVED DUPLICATE of bug 187772

Status

()

RESOLVED DUPLICATE of bug 187772
12 years ago
12 years ago

People

(Reporter: jonathanr.pritchard+bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

If a person does not clear their previous searches they will be presented with a listbox when entering into a search field be it the Firefox one, or an in-website one. E.g. google.

On sites like wikipedia and wikis in general (mininova.org tested also, does not produce same results. Possibly because a vertical scrollbar was not presented in this case). The list of saved searches pops up with a scrollbar.

When scrolling down with the mouse wheel the listbox goes down wtih the page, away from the bottom of the actual search field.

This behaviour seems broken.

Reproducible: Always

Steps to Reproduce:
1. Go to en.wikipedia.org or wiki.mozilla.org
2. You must have searched for many things without clearing this memory
3. For instance in Wikipedia's searchbox typing 't' for me will bring up a list of all the searches anywhere in Firefox (not just in Wikipedia) that I have made beginning with 't'. This is a listbox, with a vertical scrollbar.
4. Scroll down the page.

Actual Results:  
The listbox with all the previous searches made will scroll down with the page, one can select items from it still to be inserted into the search box.

This behaviour seems odd, ugly and broken.

Expected Results:  
The listbox should be closing.
(Reporter)

Comment 1

12 years ago
Have now tested on www.cultdeadcow.com searchbox, same behaviour (yes sorry about the site, I had to choose to test it. First one that popped in my head).

Sorry if this is a dupe.

*** This bug has been marked as a duplicate of 187772 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.