Last Comment Bug 350455 - Japanese printing page shown garbage character.
: Japanese printing page shown garbage character.
Status: RESOLVED FIXED
: fixed1.8.1.1
Product: Core
Classification: Components
Component: Printing: Output (show other bugs)
: 1.8 Branch
: x86 Linux
: -- normal (vote)
: ---
Assigned To: ToshihiroYamagishi
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-28 04:50 PDT by ToshihiroYamagishi
Modified: 2006-11-29 18:17 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
set face index correctly. (705 bytes, patch)
2006-08-28 04:56 PDT, ToshihiroYamagishi
bzbarsky: superreview+
dveditz: approval1.8.1.1+
Details | Diff | Splinter Review

Description ToshihiroYamagishi 2006-08-28 04:50:37 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.8.0.6) Gecko/20060825 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.8.0.6) Gecko/20060825 Firefox/1.5.0.6

Print Japanese webpage with TTC fonts, the some character are shown as boxes.


Reproducible: Always
Comment 1 ToshihiroYamagishi 2006-08-28 04:56:09 PDT
Created attachment 235732 [details] [diff] [review]
set face index correctly.
Comment 2 ToshihiroYamagishi 2006-08-28 05:01:18 PDT
This problem is caused by the gfx PS generator which does not handle TTC face index correctly.I've made a patch to fix this problem.
Comment 3 Kevin Brosnan 2006-08-28 05:09:16 PDT
You should request review from  one of the HTML to PS peers http://www.mozilla.org/owners.html#html-to-text-postscript-translation
Comment 4 Boris Zbarsky [:bz] 2006-08-28 08:45:00 PDT
Comment on attachment 235732 [details] [diff] [review]
set face index correctly.

vlad, do you think you can review this?  I'm really not very familiar with XFT stuff...

If you're not comfortable with this, do you know who might be?
Comment 5 Behdad Esfahbod 2006-11-10 12:57:15 PST
The patch looks good.  It does exactly what cairo and Xft do.
Comment 6 Boris Zbarsky [:bz] 2006-11-10 20:53:42 PST
Comment on attachment 235732 [details] [diff] [review]
set face index correctly.

Sounds like an r+ to me.  ;)  I'll go out on a limb here and sr.
Comment 7 Boris Zbarsky [:bz] 2006-11-10 20:58:50 PST
I checked in the fix on trunk.  Should we try to fix this on the 1.8 branch as well?  How serious a problem is it in daily use?
Comment 8 Jungshik Shin 2006-11-10 21:34:01 PST
(In reply to comment #7)
> I checked in the fix on trunk.  Should we try to fix this on the 1.8 branch as
> well?  How serious a problem is it in daily use?

As far as I know, there's no free TTC (true type collection) font available for Linux, which is why I haven't stumbled upon the problem. Some Linux users just copy TTCs from their Windows and there might be some commercial TTC fonts used by Linux users (or other Unix users).

Anyway, the patch is simple and safe enough so that I'd fix it in the 1.8 branch.
Comment 9 Boris Zbarsky [:bz] 2006-11-10 21:42:26 PST
Comment on attachment 235732 [details] [diff] [review]
set face index correctly.

Should be pretty safe and helps with some non-Western fonts, apparently...
Comment 10 Daniel Veditz [:dveditz] 2006-11-29 11:58:08 PST
Comment on attachment 235732 [details] [diff] [review]
set face index correctly.

approved for 1.8 branch, a=dveditz for drivers
Comment 11 Boris Zbarsky [:bz] 2006-11-29 18:17:39 PST
Checked in for 1.8.1.1.

Note You need to log in before you can comment on or make changes to this bug.