Odd floating bug, only occurs in Gecko.

RESOLVED DUPLICATE of bug 290146

Status

()

Core
Layout: Floats
RESOLVED DUPLICATE of bug 290146
11 years ago
11 years ago

People

(Reporter: Markus Lindström, Unassigned)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
I've stumbled upon an issue when designing a Web site using floats. I'd have a hard time explaining things, so I'll just get to the URIs:

http://www.friskissvettis.be/indexp.php
http://www.friskissvettis.be/indexp.php?nodate=true

The only difference between those two pages is the removal of the small DIV showing the date above the main contents. Now, I know IE6 and even 7 are nothing to go by, but this weirdness doesn't occur in Opera 9 nor Safari (checked through BrowsrCamp), either.

Anyway, I'm really stumped, and I can't tell whether I've hit a Gecko rendering bug or whether all other engines are violating the standards.

It should be noted that the bug can only be reproduced if the DIV is removed altogether; leaving an empty DIV doesn't break the page.

I've reproduced the bug on Firefox 1.5 and 2.0b2.
Could you attach a minimized testcase to the bug?
(Reporter)

Comment 2

11 years ago
Thanks for your attention, Gavin. I'll work on building a testcase right away, give me a few hours. ;-)

Meanwhile, I've checked with both Minefield and dbaron's reflow branch; both suffered from the same issue, so I guess this targets the trunk.
OS: Windows XP → All
Version: 1.8 Branch → Trunk
(Reporter)

Comment 3

11 years ago
Created attachment 235753 [details]
Preliminary testcase

I've managed to boil it down to this. I'm not sure whether it's any good, though; the issue seems quite hazy.
(Reporter)

Updated

11 years ago
Keywords: testcase
(Reporter)

Comment 4

11 years ago
Good news; I've managed to get rid of the discreptancy by setting the 'clear' property on what would be the blue DIV in the testcase. So I guess it was bad programming on my part after all... Still, a question remains: does the fact that this occurs show a Gecko bug, or are the other engines violating the standard?

Comment 5

11 years ago
Created attachment 235998 [details]
minimal test case

This happens when the non floated element establishes a new block formatting context CSS 2.1, 9.4.1.
The element is to wide to fit next to the floated block, and should drop below the floated block, according to CSS 2.1, 9.5.

*** This bug has been marked as a duplicate of 290146 ***
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.