Closed Bug 350506 Opened 14 years ago Closed 12 years ago

FireFox is unable to render SQL Server Reporting Services reports

Categories

(Core :: Layout, defect)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: chrisbal, Unassigned)

References

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

A relatively simple HTML table with some associated styles renders incorrectly with FireFox.  All table column are collapsed to a very narrow width.  This page renders correctly in IE7 and Opera.

Reproducible: Always

Steps to Reproduce:
1. Load the HTML page that I pasted in the Additional Information section
Actual Results:  
FireFox renders the table with all columns collapsed to a very narrow width, making the table cell data unreadable.  This renders fine in IE7 and Opera.

Expected Results:  
The table and its data should be properly sized and readable.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
	<title>Report21 </title>
	<style type="text/css">
.a3{
border:1pt None Black;
background-color:Transparent;background-repeat:Repeat;padding-left:2pt;padding-top:2pt;padding-right:2pt;padding-bottom:2pt;
font-style:Normal;font-family:Tahoma;font-size:20pt;font-weight:Bold;text-decoration:None;direction:LTR;unicode-bidi:Normal;text-align:left;writing-mode:lr-tb;vertical-align:Top;color:SteelBlue;}

.a4{
border:1pt None Black;
background-color:Transparent;background-repeat:Repeat;padding-left:0pt;padding-top:0pt;padding-right:0pt;padding-bottom:0pt;border-collapse:collapse}

.a10{
border:1pt Solid #d3d3d3;
background-color:SteelBlue;background-repeat:Repeat;padding-left:2pt;padding-top:2pt;padding-right:2pt;padding-bottom:2pt;
font-style:Normal;font-family:Tahoma;font-size:11pt;font-weight:Bold;text-decoration:None;direction:LTR;unicode-bidi:Normal;text-align:Right;writing-mode:lr-tb;vertical-align:Top;color:White;word-wrap:break-word}

.a11{
border:1pt Solid #d3d3d3;
background-color:SteelBlue;background-repeat:Repeat;padding-left:2pt;padding-top:2pt;padding-right:2pt;padding-bottom:2pt;
font-style:Normal;font-family:Tahoma;font-size:11pt;font-weight:Bold;text-decoration:None;direction:LTR;unicode-bidi:Normal;text-align:left;writing-mode:lr-tb;vertical-align:Top;color:White;word-wrap:break-word}

.a12{
border:1pt Solid #d3d3d3;
background-color:SteelBlue;background-repeat:Repeat;padding-left:2pt;padding-top:2pt;padding-right:2pt;padding-bottom:2pt;
font-style:Normal;font-family:Tahoma;font-size:11pt;font-weight:Bold;text-decoration:None;direction:LTR;unicode-bidi:Normal;text-align:left;writing-mode:lr-tb;vertical-align:Top;color:White;word-wrap:break-word}

.a18{
border:1pt Solid #d3d3d3;
background-color:Transparent;background-repeat:Repeat;padding-left:2pt;padding-top:2pt;padding-right:2pt;padding-bottom:2pt;
font-style:Normal;font-family:Tahoma;font-size:10pt;font-weight:Normal;text-decoration:None;direction:LTR;unicode-bidi:Normal;text-align:right;writing-mode:lr-tb;vertical-align:Top;color:Black;word-wrap:break-word}

.a19{
border:1pt Solid #d3d3d3;
background-color:Transparent;background-repeat:Repeat;padding-left:2pt;padding-top:2pt;padding-right:2pt;padding-bottom:2pt;
font-style:Normal;font-family:Tahoma;font-size:10pt;font-weight:Normal;text-decoration:None;direction:LTR;unicode-bidi:Normal;text-align:left;writing-mode:lr-tb;vertical-align:Top;color:Black;word-wrap:break-word}

.a20{
border:1pt Solid #d3d3d3;
background-color:Transparent;background-repeat:Repeat;padding-left:2pt;padding-top:2pt;padding-right:2pt;padding-bottom:2pt;
font-style:Normal;font-family:Tahoma;font-size:10pt;font-weight:Normal;text-decoration:None;direction:LTR;unicode-bidi:Normal;text-align:left;writing-mode:lr-tb;vertical-align:Top;color:Black;word-wrap:break-word}

.r1{HEIGHT:100%;WIDTH:100%}

.r2{HEIGHT:100%;WIDTH:100%;overflow:hidden}

.r3{HEIGHT:100%}

.r4{border-style:none}

.r5{border-left-style:none}

.r6{border-right-style:none}

.r7{border-top-style:none}

.r8{border-bottom-style:none}

.r10{border-collapse:collapse}

.r9{border-collapse:collapse;table-layout:fixed}

.r11{WIDTH:100%;overflow-x:hidden}

.r12{position:absolute;display:none;background-color:white;border:1px solid black;}

.r13{text-decoration:none;color:black;cursor:pointer;}</style>
</head>
<body style="border: 0px; margin: 0px; padding: 0px">
	<div id="oReportDiv">
		<table cellspacing="0" cellpadding="0">
			<tr>
				<td bgcolor="green" id="oReportCell">
					<div>
						<table cellspacing="0" cellpadding="0" border="0" cols="2" lang="en-US" class="r10">
							<tr valign="top">
								<td colspan="2" style="height: 10.92mm">
									<table cellspacing="0" cellpadding="0" lang="en-US" class="a4" cols="3">
										<tr style="height: 5.59mm">
											<td class="a10">
												<div class="r11">
													contactid</div>
											</td>
											<td class="a11">
												<div class="r11">
													firstname</div>
											</td>
											<td class="a12">
												<div class="r11">
													lastname</div>
											</td>
										</tr>
										<tr>
											<td style="height: 5.33mm" class="a18">
												<div class="r11">
													1</div>
											</td>
											<td class="a19">
												<div class="r11">
													Gustavo</div>
											</td>
											<td class="a20">
												<div class="r11">
													Achong</div>
											</td>
										</tr>
										
									</table>
								</td>
							</tr>
						</table>
					</div>
				</td>
				<td bgcolor="red" width="100%" height="0">
				</td>
			</tr>
			<tr>
				<td bgcolor="blue" width="0" height="100%">
				</td>
			</tr>
		</table>
	</div>
</body>
</html>
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → 1.8 Branch
(In reply to comment #2)
> This behaviour changed a long time ago:
> http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=2004-09-04+06%3A00&maxdate=2004-09-05+08%3A00
> 

Thanks, but I'm not sure what you mean here.  The current behavior I'm seeing in the version I noted is considered to be correct?  Can you elaborate on what you mean by your comment?
2004-09-04 was the date when it still worked as intended, but on 2004-09-05 the columns rendered collapsed. Between those two dates something changed in the code.
(In reply to comment #4)
> 2004-09-04 was the date when it still worked as intended, but on 2004-09-05 the
> columns rendered collapsed. Between those two dates something changed in the
> code.
> 

To clarify, this has been working improperly since Sept 2004?  Our application auto-generates HTML for reports that look great in every browser we test with except for FireFox (because of this issue) so it impacts many people.  A fix for this would be really great, though I'm not sure where this sits on your priority list.   Thanks!
More info to hopefully help prioritization: We are getting more and more reports of users who cannot view SQL Server Reporting Services reports with FireFox while they can with other browsers (IE, Opera). We really want users of FireFox to be able to consume Reporting Services reports, so this is quite troublesome.
Summary: Table columns render collapsed, truncates data → FireFox is unable to render SQL Server Reporting Services reports
This won't probably make Firefox 2.0 anymore, but possibly it will be fixed in Firefox 3.0.
In these builds I don't see this bug anymore:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/experimental/reflow-refactor/latest-trunk/
Version: 1.8 Branch → Trunk
Indeed. This is fixed (or works again) in Firefox 3 and higher.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Flags: in-testsuite?
Resolution: --- → WORKSFORME
Attached patch reftestSplinter Review
Only in Fx2, "table-cell" is invisible.
Attachment #356332 - Flags: superreview?(dbaron)
Attachment #356332 - Flags: review?(dbaron)
Attachment #356332 - Flags: superreview?(dbaron)
Attachment #356332 - Flags: superreview+
Attachment #356332 - Flags: review?(dbaron)
Attachment #356332 - Flags: review+
Keywords: checkin-needed
http://hg.mozilla.org/mozilla-central/rev/22cd72d31090
Flags: in-testsuite? → in-testsuite+
Keywords: checkin-needed
You need to log in before you can comment on or make changes to this bug.