Last Comment Bug 350617 - repeat attrs not working on xf:group element
: repeat attrs not working on xf:group element
Status: RESOLVED WONTFIX
:
Product: Core Graveyard
Classification: Graveyard
Component: XForms (show other bugs)
: Trunk
: x86 Windows XP
: -- normal with 1 vote (vote)
: ---
Assigned To: xforms
: Stephen Pride
Mentors:
http://www.w3.org/MarkUp/Forms/Test/X...
Depends on:
Blocks: 322255
  Show dependency treegraph
 
Reported: 2006-08-29 12:27 PDT by Steve Speicher
Modified: 2016-07-15 14:46 PDT (History)
1 user (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
testsuite testcase with just group (1.04 KB, application/xhtml+xml)
2006-08-29 12:28 PDT, Steve Speicher
no flags Details

Description Steve Speicher 2006-08-29 12:27:24 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060828 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060828 Minefield/3.0a1

repeat attributes have no effect on <xforms:group>

Reproducible: Always
Comment 1 Steve Speicher 2006-08-29 12:28:21 PDT
Created attachment 235947 [details]
testsuite testcase with just group
Comment 2 Steve Speicher 2006-08-29 12:29:41 PDT
This fails W3C testsuite non-normative case 9.3.2.a
Comment 3 aaronr 2006-08-29 15:27:56 PDT
The hack that is currently in place for repeat attributes will be ignored for any element that has xbl bindings applied by a more specific css rule.  Since every xforms element has at least one binding in place, we'd need to special case the elements that we want to support having @repeat-nodeset.  Group is about the only xforms element I think might make good use of this attribute.  But I can also see the argument that introducing yet another binding to support this might just introduce more headaches.  Particularly since any binding/style rules we introduce for xf:group to support this would need to keep in sync with any other style rules for group that might otherwise be conflict (including the current binding for xf:group).  A group with repeat attributes needs to look/behave like any other xf:group except for the repeating content, of course.
Comment 4 David Bolter [:davidb] ***PTO until 29th*** 2016-02-04 12:22:19 PST
RIP xforms

Note You need to log in before you can comment on or make changes to this bug.