Firefox restart required after IP address changes when hot-swapping laptop (ff using automatic proxy URL connection)

RESOLVED DUPLICATE of bug 213637

Status

()

RESOLVED DUPLICATE of bug 213637
12 years ago
11 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

This bug has been present for me since release 1.5 of Firefox. I figured that if I wait a few releases, it would be fixed, but it is not therfore I am reporting it.

Firefox and other apps are configured to use an automatic proxy URL. I have a firefox window open and other internet applications (such as IE, Lotus Notes, Samtime, Miranda IM client) open on my laptop. I have to change offices so I either get disconnected from a wireless network or phisically unplug the network cable. I go to the new location and re-establish the internet connection (all apps are still open). Basically I hot-swap my laptop from one network to another. All applications regain normal behaviour except firefox. If I refresh a page or click on a link or bookmark, it shows the busy icon for a while and then a blank page appears. I have to close firefox and re-open it to get it to work again. This is very annoying.

I do have extensions, so I don't know if maybe one of them is causing this. I tried to find a log file to help me pinpoint the problem, but had no luck. Maybe you can let me know how to do this.

Reproducible: Always

Steps to Reproduce:
1. configure firefox to use automatic proxy URL for internet connection (since I am behind a firewall)
2. boot computer, start firefox and go to any URL
3. hot-swap networks (that still use the same proxy URL): change to new IP without closing applications but disconnect/unplug from network and plug into a differnt one. May or may not hibernate (makes no difference)
4. re-establish network on computer
5. try to re-fresh the page in firefox or go to a new URL. 
Actual Results:  
You get a wait icon, and after 30 secs or so, the page is not refreshed or is blank (white). To regain browsing capability, you need to close and re-start firefox.


Expected Results:  
Firefox should have been able to refresh the page or go to new URL's, after a network has been established, without having to close and restart firefox. This behaviour was present in pre 1.5 versions of firefox.

The browser connects through an automatic proxy URL. Hot swapping between offices or buildings that are all behind the same firewall and use the same proxy URL.

Installed extensions:
- Google Toolbar for Firefox 2.1.20060807W
- Forecastfox 0.9.3
- IE Tab 1.0.9.5
- PDF Download 0.7.4
- Tab Mix Plus 0.3.0.5
- Map This 0.1.5
- Adblock Filterset.G Updater 0.3.0.4
- Answers 2.1.12
- Adblock Plus 0.7.1.2
- Dictionary Tooltip 0.9.1
- GooglePreview 1.3.3
- Download Statusbar 0.9.4.1
- Stock Ticker 1.0.3
- Talkback 1.5.0.6
- VideoDownloader 1.0

Comment 1

11 years ago
If you can reproduce this bug, and if when the problem occurs
Firefox is consuming 100% CPU usage, please go to bug 213637
comment 57 and help me test my patch.  Thanks.

Comment 2

11 years ago
I believe this bug is a duplicate of bug 213637.  I just checked
in a fix for bug 213637.  If you're still seeing this problem,
please go to bug 213637 comment 57 and test my special Firefox
build.  Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 213637
You need to log in before you can comment on or make changes to this bug.