Closed Bug 350920 Opened 13 years ago Closed 12 years ago

update doesn't start downloading in the background

Categories

(Toolkit :: Application Update, defect, major)

defect
Not set
major

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jbecerra, Unassigned)

Details

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1

While trying litmus test case #2459, I found that the automatic update check works, but it doesn't start downloading it in the background. The Help menu item does say "Downloading 2.0b2..." but never starts the download unless you select the item.

To reproduce:
1. Download and install release 2.0beta1 and set "betatest" in the channel-prefs.js file
2. Launch FF and in the Preferences|Security, Updates tab check "Automatically download and install the update"
3. Go to about:config and set app.update.interval to 90 (seconds), so that Firefox checks for updates every 90 seconds.
4. Restart and relaunch.

Expected: After 90 seconds FF should start downloading the update and when finished it should prompt you to restart for it to be applied.

Actual: You can see the Help menu item that says "Downloading 2.0b2..." but it never starts the download. If you select that item, then it will bring up the dialog window and start the update.
Did you forget to mention changing app.update.timer ? Otherwise the timer will fire every 10 minutes.
I set the app.update.timer to 5000 and the app.update.interval to 60.
It turns out the file is downloaded in the backgroundd (slowly), but you have to check its progress by checking the size of the update.mar file. I updated the litmus test to reflect this. Marking as worksforme.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
I see this on TB everyday. What does it download at, like .0002 KB a second? Because it seems to me like it doesn't start until I open the windows by tools->"Downloading whatever it says"
(In reply to comment #4)
> I see this on TB everyday. What does it download at, like .0002 KB a second?
> Because it seems to me like it doesn't start until I open the windows by
> tools->"Downloading whatever it says"
> 

Oops forgot to mention that like today I got to work and I've had Firefox open for past three days and it was still downloading the build from the 27th. Opend the window and i swear it had just started then and finished in about 15 seconds.
It downloads at 64kb/min max (some hard coded setting). So that if you leave it "Downloading...", when you open that menu item it will pick up from wherever it currently has downloaded and download the rest, in the foreground.

http://lxr.mozilla.org/mozilla1.8/source/toolkit/mozapps/update/src/nsUpdateService.js.in#98
Just tried again and waited about 5 minutes. Opened up the window through Help, "Downloading ..." and said connecting to server, then size shown was 64kb download then finished about 4 seconds later. So it's not downloading in the background. Like i said earlier i left my firefox at work run for past 4 days without restarting and the build to update to the 28th from the 26th did not download at all during that time. Should have been downloading the 7.1mb or whatever size file in that ammount of time but it did not even start downloading until i opened that window.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Kurt, are you using Trunk or 1.8 Branch when you have these problems ? 

Also, the background mode isn't really aimed at nightly users. Most people set the update prefs to "Ask me ..." and then get the full speed of the foreground d/l when they accept the offer. I don't mean that we shouldn't test this though, since many (the majority ?) of release installs will update like this.
(In reply to comment #8)
> Kurt, are you using Trunk or 1.8 Branch when you have these problems ? 
> 

trunk, I'll get beta 1 and try updating to beta 2 in the background later today. Even better I will try RC1 to beta 2 since that will be a full update (like 7mb correct?) When I tried with trunk I went back a few days so I would have to download the whole update and waited 5 minutes so it should have been about a mb or so download but it wasn't.

Ok, skipped a day updating so i'd get offered the full update and it'd download in the background. Checked today and it was at 5.0mb so it is working properly. Appears that I just always happened to open it right after it started. Resolving WFM.
Status: REOPENED → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → WORKSFORME
This issue isn't WFM and can easily be reproduced with current trunk builds:

1. Download and install a nightly build which is at least two days old
2. Start Minefield and go to "Check for Updates".
3. Start downloading the full mar package.
4. Close Minefield before the download has finished.
5. Restart Minefield

Now the help menu states that the update is currently downloaded but no download is started. You have to wait forever and won't get any updates until you manually open the software update dialog.

Asking for blocking because this can prevent users from getting any update.

This bug causes bug 353804 which I filed a while ago and happens for trunk and 1.8 branch builds.
Blocks: 353804
Severity: normal → major
Status: RESOLVED → REOPENED
Flags: blocking-firefox3?
OS: Mac OS X → All
Hardware: Macintosh → All
Resolution: WORKSFORME → ---
Target Milestone: Firefox 2 → ---
Version: 2.0 Branch → Trunk
Henrik, that seems like a different bug than this, which is that it never starts in the background.  Please file a new bug with the steps to reproduce.
Status: REOPENED → RESOLVED
Closed: 13 years ago12 years ago
Flags: blocking-firefox3?
Resolution: --- → WORKSFORME
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.