Closed Bug 351013 Opened 14 years ago Closed 14 years ago

"Raise or lower windows" isn't checked

Categories

(Firefox :: Preferences, defect)

2.0 Branch
x86
Windows XP
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: mjuhos, Unassigned)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2

After instaling Firefox 2 is unchecked item "Raise or lower windows", even if it was checked in older Firefox versions.

Reproducible: Always

Steps to Reproduce:
1. Install Firefox 2 Beta2
2. See Settings->Content->Advanced->"Raise or lower windows"

Actual Results:  
Checkbox is unchecked.

Expected Results:  
Checkox will be checked.

This problem could affect behavior of many web applications workings with windows (window.focus() has no effect and there is no workaround).
Flags: blocking-firefox2?
Version: unspecified → 2.0 Branch
Yeah, because it was the default setting in Firefox 1.5x to allow websites to raise or lower windows. Only if you change a pref, that change will be written to pref.js. Since there is no user set change, the next build (2.0) will also use its default and that not to allow it.
You can prevent that change by writing the pref to user.js.
http://kb.mozillazine.org/User.js
(In reply to comment #1)

> to pref.js.
Sorry typo, should be prefs.js.
> Since there is no user set change, the next build (2.0) will also
use its default and that not to allow it.

Yes, this is the problem. Default value was changed and it means majority of users will have this option unchecked.

I don't see reason why default value was changed.
We only turned this off in Firefox 1.5 because it broke Gmail, the original intent was to always leave this pref unchecked, so this is WONTFIX.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → WONTFIX
Flags: blocking-firefox2? → blocking-firefox2-
The intent seems to come from bug 299424 comment 7:

> I don't think many web applications need it, and those
> that use it shouldn't be horribly broken if they can't
> control window focus.

Well, we do need window.focus() in Kerio (.com) WebMail:

1. Alarm window for meetings. If it pops up and the user puts it to background, we have no way to bring it to front again when the meeting starts.

2. Windows opened on demand. We use your Best practices from
http://developer.mozilla.org/en/docs/window.open#Best_practices
We call focus() for a window already existing in background to put it to front. Since Firefox 2 it's not possible and some buttons will seem as broken for an average user.

There's no workaround. Closing and re-opening the window is not an option, it would mean data loss if the window was opened and edited earlier.

Of course it's possible to change the option in settings, but from our experience majority of people never change any settings. They expect that things just work. Firefox users are more technical than average, but with global share 12%+ and climbing it has hit that majority already.

This bug together with bug 354123 make working with windows harder again for web app authors (modal windows don't work in Firefox for years already). I don't think we are alone who need windows for legal purposes.

Please re-evaluate this.
We were forced to make an explanatory window on our login page. Really not nice :-(
i'd suggest you consider emulating gmail, instead of trying to pop open windows, just pollute all open windows with the notice.
But we do want to use windows, for reasons like allowing multitask work (as opposed to gmail).

Your suggestion basically limits our (web app authors') choice. I don't understand how this goes together with Mozilla Foundation mission.
> 1. Alarm window for meetings. If it pops up and the user puts it to background,
> we have no way to bring it to front again when the meeting starts.

Can't do much about that without letting in annoyances :(  Unless it becomes a per-site pref or somemthing.

Have you tried using alert() when focus() fails?  I think that makes taskbar icons flash / dock icons bounce if the window is in the background.  And it does something reasonable for background tabs, too.

Another possibility is to use sounds.  (I think Gmail does this for chats.)

> 2. Windows opened on demand. We use your Best practices from
> http://developer.mozilla.org/en/docs/window.open#Best_practices
> We call focus() for a window already existing in background to put it to front.
> Since Firefox 2 it's not possible and some buttons will seem as broken for an
> average user.

Fixing bug 355482 will take care of this.
Yes we tried alert(), it works, but it doesn't fit well into our application. We didn't go into remaking whole reminder system as we believed this bug will be fixed...

Sound would make sense if some action on screen happens, so again "show it without windows".

Anyway thanks for the hints, they may help somewhere else at least.

> Fixing bug 355482 will take care of this.

Nice. Any chance to Firefox 2 or 2.0.x?
(In reply to comment #1)
> it was the default setting in Firefox 1.5x to allow websites to
> raise or lower windows.

Actually, that's not true. See bug 318535 
Firefox 1.5.x and now Firefox 2 ignore the user setting and will turn off raise or lower setting when upgrading. I think this is wrong.
Most likely the same thing happening now with bug 356646
*** Bug 356646 has been marked as a duplicate of this bug. ***
*** Bug 318535 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.