Closed Bug 351063 Opened 15 years ago Closed 15 years ago

navigator.userAgent shows just "/" for suiterunner's extra portion (browser-prefs.js not preprocessed correctly)

Categories

(SeaMonkey :: Build Config, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: standard8, Assigned: standard8)

References

Details

Attachments

(1 file)

Either apply various fixes to get about: working, or go into the error console on suiterunner and type

navigator.userAgent

The string you'll get back will look like:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060901 /

instead of:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060901 SeaMonkey/1.5a

The problem is that we haven't got some required defines in one of the makefiles.

It turns out we're not preprocessing browser-prefs.js correctly as app.releaseNotesURL is also wrong.
(In reply to comment #0)
> It turns out we're not preprocessing browser-prefs.js correctly as
> app.releaseNotesURL is also wrong.

Ignore that, app.releaseNotesURL is a separate bug...
Attached patch The fixSplinter Review
Add defines to the makefile for name/version so that the preprocessor knows about them. This was missed when I originally did the move for browser-prefs.js for suiterunner.
Attachment #236462 - Flags: superreview?(neil)
Attachment #236462 - Flags: review?(neil)
Attachment #236462 - Flags: superreview?(neil)
Attachment #236462 - Flags: superreview+
Attachment #236462 - Flags: review?(neil)
Attachment #236462 - Flags: review+
Patch checked in:

/cvsroot/mozilla/suite/browser/Makefile.in,v  <--  Makefile.in
new revision: 1.3; previous revision: 1.2
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.