Closed Bug 351136 Opened 15 years ago Closed 15 years ago

Downloading should not freeze main window

Categories

(Toolkit :: Downloads API, defect)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 159107

People

(Reporter: artorrijos, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2

Whenever I click on a link to download a file, the browser window will be unresponsive until the download successfully initiates and progresses. This is the case even when I want to download an image from an existing page, like when I view the background image and try to save it. 

I don't want any unresponsiveness whenever I download something from an existing page or even from links to files.

The browser needs to be able to use the cached image or have the download as a separate thread.

Reproducible: Always

Steps to Reproduce:
1. On an existing page, right-click and select view background image.
2. Right-click on image and do a Save.
3. Browser window becomes unresponsive while the download takes place and takes several seconds before it becomes responsive again.

Actual Results:  
Browser window was clickable but unresponsive and I see the error on the title bar, browser Not Responding.

Expected Results:  
Downloading an image from an existing page should not render main window from being unresponsive.
Please clean up your downloads manager or delete downloads.rdf in your profile.

*** This bug has been marked as a duplicate of 159107 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.