CGI::Carp::fatalsToBrowser doesn't work under mod_perl 2.0

NEW
Unassigned

Status

()

defect
13 years ago
9 years ago

People

(Reporter: mkanat, Unassigned)

Tracking

Dependency tree / graph

Details

CGI::Carp says explicitly in its POD docs that it doesn't work with mod_perl 2. I Think that's pretty dumb--it *should* work, it would be a pretty simple code change. But it doesn't work.

So instead we'll have to write our own error handler specifically for mod_perl and use that instead of fatalsToBrowser when we have to "die" for some reason.
Bugzilla 3.0 and 3.2 are now restricted to security fixes only.
Target Milestone: Bugzilla 3.0 → Bugzilla 3.4
Bugzilla 3.4 is now restricted to security bugs. We will retarget this bug (to 3.6 or later) when it's fixed.
Target Milestone: Bugzilla 3.4 → ---
You need to log in before you can comment on or make changes to this bug.