Closed Bug 351242 Opened 17 years ago Closed 17 years ago

Rewrite textframe around gfxTextRun

Categories

(Core :: Layout: Text and Fonts, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 333659

People

(Reporter: roc, Assigned: roc)

Details

The plan is to introduce a new gfxTextRun abstraction that encapsulates the conversion of text to positioned glyphs, with roughly one gfxTextRun per uni-directional chunk of DOM text, which can persist, and is implemented per-platform. nsTextFrame is rewritten to delegate much functionality to gfxTextRun --- and to clean up a lot of problems that have crept in over the years.
The new text run also supports hyphenation (just soft hyphens for now) and is much better about character clusters.
Blocks: shy
Marking dep to bug 333659, but how are they actually related?  Are they just duplicates?
Blocks: 333659
Blocks: 351126

*** This bug has been marked as a duplicate of 333659 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Blocks: 161826
No longer blocks: 161826
Blocks: 235022
No longer blocks: shy, 235022, 351125, 351126
You need to log in before you can comment on or make changes to this bug.