Move Group validation into Bugzilla::Bug from post_bug.cgi

RESOLVED FIXED in Bugzilla 3.0

Status

()

Bugzilla
Creating/Changing Bugs
--
enhancement
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Max Kanat-Alexander, Assigned: Max Kanat-Alexander)

Tracking

2.23
Bugzilla 3.0
Dependency tree / graph
Bug Flags:
approval +

Details

Attachments

(1 attachment, 1 obsolete attachment)

6.24 KB, patch
Frédéric Buclin
: review+
Details | Diff | Splinter Review
(Assignee)

Description

11 years ago
post_bug.cgi does a lot of group validations, and these should all move into Bugzilla::Bug. Basically, this is just code that will tell us what groups the bug is in, given the product and certain input.
(Assignee)

Comment 1

11 years ago
Created attachment 236738 [details] [diff] [review]
v1

Okay, here we go. Easy, easy. Doesn't depend on any previous bugs.

This cleaned up the code a lot.
Assignee: create-and-change → mkanat
Status: NEW → ASSIGNED
Attachment #236738 - Flags: review?(bugzilla-mozilla)
(Assignee)

Updated

11 years ago
Blocks: 351339
Version: 2.99 → 2.23
(Assignee)

Updated

11 years ago
Target Milestone: --- → Bugzilla 3.0
(Assignee)

Updated

11 years ago
Attachment #236738 - Flags: review?(bugzilla-mozilla) → review?(LpSolit)
(Assignee)

Comment 2

11 years ago
Created attachment 237540 [details] [diff] [review]
v1.1

Fixed bitrot.
Attachment #236738 - Attachment is obsolete: true
Attachment #237540 - Flags: review?(LpSolit)
Attachment #236738 - Flags: review?(LpSolit)

Comment 3

11 years ago
Comment on attachment 237540 [details] [diff] [review]
v1.1

>Index: post_bug.cgi

>-        if (!GroupIsActive($v)) {

Nit: this was the single place using GroupIsActive(). Please remove this routine from post_bug.cgi on checkin as we don't use it at all anymore. r=LpSolit
Attachment #237540 - Flags: review?(LpSolit) → review+

Updated

11 years ago
Flags: approval?
Flags: approval? → approval+
(Assignee)

Comment 4

11 years ago
Okay, I did the checkin fix.

Checking in post_bug.cgi;
/cvsroot/mozilla/webtools/bugzilla/post_bug.cgi,v  <--  post_bug.cgi
new revision: 1.175; previous revision: 1.174
done
Checking in Bugzilla/Bug.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Bug.pm,v  <--  Bug.pm
new revision: 1.150; previous revision: 1.149
done
Checking in template/en/default/global/code-error.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/code-error.html.tmpl,v  <--  code-error.html.tmpl
new revision: 1.84; previous revision: 1.83
done
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 5

11 years ago
*** Bug 323240 has been marked as a duplicate of this bug. ***

Updated

11 years ago
Blocks: 328437

Updated

11 years ago
Blocks: 355744
You need to log in before you can comment on or make changes to this bug.