Move keyword insertion out of post_bug.cgi and into Bugzilla::Bug

RESOLVED FIXED in Bugzilla 3.0

Status

()

Bugzilla
Creating/Changing Bugs
--
enhancement
RESOLVED FIXED
12 years ago
10 years ago

People

(Reporter: Max Kanat-Alexander, Assigned: Max Kanat-Alexander)

Tracking

2.23
Bugzilla 3.0
Dependency tree / graph
Bug Flags:
approval +

Details

Attachments

(1 attachment, 2 obsolete attachments)

3.60 KB, patch
Frédéric Buclin
: review+
Details | Diff | Splinter Review
(Assignee)

Description

12 years ago
This one's a little trickier, because there's more code for inserting keywords. But we can handle it!
(Assignee)

Comment 1

12 years ago
Created attachment 236742 [details] [diff] [review]
v1

Here we go. Tested and works.

You'll also notice that I did a bit of refactoring in run_create_validators to make things simpler overall.
Assignee: create-and-change → mkanat
Status: NEW → ASSIGNED
Attachment #236742 - Flags: review?(bugzilla-mozilla)
(Assignee)

Comment 2

12 years ago
Created attachment 236839 [details] [diff] [review]
v1.1

Fixed bitrot.
Attachment #236742 - Attachment is obsolete: true
Attachment #236839 - Flags: review?(bugzilla-mozilla)
Attachment #236742 - Flags: review?(bugzilla-mozilla)
Version: 2.99 → 2.23
(Assignee)

Updated

12 years ago
No longer depends on: 351339
(Assignee)

Updated

12 years ago
Attachment #236839 - Flags: review?(bugzilla-mozilla) → review?(LpSolit)
(Assignee)

Updated

12 years ago
Blocks: 351877

Comment 3

12 years ago
Comment on attachment 236839 [details] [diff] [review]
v1.1

The patch is slightly bitrotten. I will attach the unbitrotten one in a few seconds. Your patch is working fine. r=LpSolit
Attachment #236839 - Flags: review?(LpSolit) → review+

Comment 4

12 years ago
Created attachment 237463 [details] [diff] [review]
patch, v1.2

Here is the one I tested.
Attachment #236839 - Attachment is obsolete: true
Attachment #237463 - Flags: review+

Updated

12 years ago
Flags: approval?
Flags: approval? → approval+
(Assignee)

Comment 5

12 years ago
Checking in post_bug.cgi;
/cvsroot/mozilla/webtools/bugzilla/post_bug.cgi,v  <--  post_bug.cgi
new revision: 1.177; previous revision: 1.176
done
Checking in Bugzilla/Bug.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Bug.pm,v  <--  Bug.pm
new revision: 1.152; previous revision: 1.151
done
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 6

12 years ago
*** Bug 323241 has been marked as a duplicate of this bug. ***
I must say I usually add some keyword for completeness. Doing it after bug report seems to be spam, IMO.

Can I open a bug to request to move back keyword insertion into enter_bug.cgi?
(Assignee)

Comment 8

10 years ago
(In reply to comment #7)
> Can I open a bug to request to move back keyword insertion into enter_bug.cgi?

  Um, it's still on enter_bug. This bug has nothing to do with the UI.
I don't see it. Fields displayed are Product, Component, Hardware, OS, Identifier, URL, Summary, Details, Reproducible, Steps, Result, Expected, Other info, Security, Severity.
You need to log in before you can comment on or make changes to this bug.