.parentlock is created in the profile directory (hosted on an OS X Open Directory server) but not deleted after Firefox is closed

RESOLVED DUPLICATE of bug 318801

Status

()

--
critical
RESOLVED DUPLICATE of bug 318801
12 years ago
10 years ago

People

(Reporter: rbigner, Unassigned)

Tracking

1.8 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

Firefox creates .parentlock in the profile directory of the user when started. However that file remains until deleted by the user and prevents the user from starting Firefox on another client. The error message follows.

Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system.

Reproducible: Always

Steps to Reproduce:
1. Create a user in Workgroup Manager (OS X Server 10.4.7 PPC).
2. Create a home directory on that server shared through AFP.
3. Login as that user on a client machine (OS X 10.4.7 Intel).
4. Start Firefox.
5. Close Firefox.
6. Log out.
7. Log into another client.
8. Try to start Firefox.

Actual Results:  
I get the error I typed above. I get the same error but with a slightly different wording when both clients are running Firefox 2.0 Beta 2. However, it works fine when both are running Firefox 3.0a1 (20060905).

Expected Results:  
I assume that it's supposed to delete .parentlock when it closes.

Comment 1

12 years ago
If you could find out when it was fixed in Firefox 3 then we might be able to pinpoint which patch it was that fixed it. (Although at this point the chances of getting that patch into Firefox 2 are pretty slim.)

Older builds are available on http://archive.mozilla.org/pub/firefox/nightly.
Version: unspecified → 2.0 Branch

Comment 2

12 years ago
Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7 and 1.5.0.6.
All the profiles have .parentlock in them, whether Fx is running or not. Some people have, indeed, problems with the file in different OSes, but I never did.

Comment 3

12 years ago
On AFS, this file makes Fx refuse to start.
Maybe bug 318801 should depend on this one.

Comment 4

12 years ago
Oh, sorry. Didn't read well.
Probably the two bugs are the same.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 318801
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.