Accessing the new navigator.buildID in a build w/o NS_BUILD_ID set shouldn't throw exception.

RESOLVED FIXED

Status

()

RESOLVED FIXED
12 years ago
8 years ago

People

(Reporter: jst, Assigned: jst)

Tracking

({fixed1.8.1})

Trunk
fixed1.8.1
Points:
---
Bug Flags:
blocking1.8.1 +
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

12 years ago
Right now if you access navigator.buildID in anything other than an official build you'll get an exception. This is not a big problem for code in general, but it's already been reported that one web app (zimbra) triggers this and the way it does it is by enumerating the properties on the navigator object.

The fix for this is trivial, patch coming up.
(Assignee)

Comment 1

12 years ago
Created attachment 237006 [details] [diff] [review]
Don't throw if NS_BUILD_ID is not set.
Assignee: general → jst
Status: NEW → ASSIGNED
Attachment #237006 - Flags: superreview?(bugmail)
Attachment #237006 - Flags: review?(bugmail)
(Assignee)

Updated

12 years ago
Flags: blocking1.8.1?
(Assignee)

Comment 2

12 years ago
The buildID navigator property was introduced by bug 345993.
(Assignee)

Updated

12 years ago
Depends on: 345993
See also bug 348069
*** Bug 348069 has been marked as a duplicate of this bug. ***
Attachment #237006 - Flags: superreview?(bugmail)
Attachment #237006 - Flags: superreview+
Attachment #237006 - Flags: review?(bugmail)
Attachment #237006 - Flags: review+
(Assignee)

Updated

12 years ago
Attachment #237006 - Flags: approval1.8.1?
(Assignee)

Comment 5

12 years ago
Fix landed on the trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Flags: blocking1.8.1? → blocking1.8.1+
Comment on attachment 237006 [details] [diff] [review]
Don't throw if NS_BUILD_ID is not set.

a=beltzner on behalf of 181drivers
Attachment #237006 - Flags: approval1.8.1? → approval1.8.1+
(Assignee)

Comment 7

12 years ago
Fix landed on the 1.8.1 branch.
Keywords: fixed1.8.1

Comment 8

12 years ago
RCS file: /cvsroot/mozilla/testing/mochitest/tests/test_bug351601.html,v
done
Checking in test_bug351601.html;
/cvsroot/mozilla/testing/mochitest/tests/test_bug351601.html,v  <--  test_bug351601.html
initial revision: 1.1
done
Flags: in-testsuite+

Updated

8 years ago
You need to log in before you can comment on or make changes to this bug.