Application stalls if attempting to print any December

VERIFIED FIXED in Sunbird 0.3

Status

--
major
VERIFIED FIXED
12 years ago
12 years ago

People

(Reporter: sebo.moz, Assigned: jminta)

Tracking

Trunk
Sunbird 0.3
x86
Windows XP

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
Attempting to print any December as Monthly Grid stalls the application. After some while a dialog pops up (Warning: unresponsive script...). Pressing Print afterwards produces an empty paper.

Steps to reproduce:

1. go to any December (Month View)
2. select Print, Monthly Grid

Result: Application does not respond for a while. 

using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060908 Calendar/0.3a2+
(Reporter)

Comment 1

12 years ago
Request blocking0.3 because printing of Monthly Grid of December is not possible.
Flags: blocking0.3?
If this is reproducible, we should block on it.
Flags: blocking0.3? → blocking0.3+
Keywords: qawanted
Confirming on
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060909 Calendar/0.3a2+
Status: UNCONFIRMED → NEW
Ever confirmed: true
So eventually the "Warning: Unresponsive Script" dialog appears.

Clicking on "Debug Script" spat out a stack 238321 lines long (literally).
Most of it is html.  Here are some highlights:

------------------------------------------------------------------------
Hit JavaScript "debugger" keyword. JS call stack...
0 anonymous(a = 6, 1, 0,6) ["file:///Users/mwillis/moz/printing/mozilla/obj-i386-apple-darwin8.7.1/dist/CalendarDebug.app/Contents/MacOS/js/calMonthGridPrinter.js":256]
    this = [object BackstagePass]
1 [native frame]
2 makeHTMLWeek(sortedList = , targetMonth = 2, date = 2077/03/18 00:00:00 /mozilla.org/20050126_1/America/New_York) ["file:///Users/mwillis/moz/printing/mozilla/obj-i386-apple-darwin8.7.1/dist/CalendarDebug.app/Contents/MacOS/js/calMonthGridPrinter.js":256]
    weekRow = <tr>
(html follows...)

Note the "date = 2077/03/18"
I had 2006-12-07 selected when I printed.


It's pretty exceptional. I'll attach it.
Created attachment 237563 [details]
Big ol' stack. It's 112kb zipped, and 8.2mb unzipped.

The stack.
...and just for fun, I tried replicating it in

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060907 Calendar/0.3a2+

...which I did.  This gives dmose/jminta's selection patch an alibi, since it wasn't checked in until that evening. (The nightly is from 07:32)
(Assignee)

Comment 7

12 years ago
Created attachment 237566 [details] [diff] [review]
.compare

Of course the month will always be less than or equal to 12. :-)
Assignee: nobody → jminta
Status: NEW → ASSIGNED
Attachment #237566 - Flags: second-review?(dmose)
Attachment #237566 - Flags: first-review?(mattwillis)
Comment on attachment 237566 [details] [diff] [review]
.compare

r1=lilmatt

Moving r2 to mvl as dmose is swamped.
Attachment #237566 - Flags: second-review?(mvl)
Attachment #237566 - Flags: second-review?(dmose)
Attachment #237566 - Flags: first-review?(mattwillis)
Attachment #237566 - Flags: first-review+
Comment on attachment 237566 [details] [diff] [review]
.compare

r2=mvl
Attachment #237566 - Flags: second-review?(mvl) → second-review+
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Keywords: qawanted
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 12

12 years ago
verified with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060917 Calendar/0.3a2+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.