Russian UTF-8 text (stored and served as UTF-8) shows up as ????'s within select options

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
11 years ago
6 years ago

People

(Reporter: Brett Zamir, Unassigned)

Tracking

({qawanted})

1.8 Branch
PowerPC
Mac OS X
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

My site has UTF-8 text in Russian (stored in the database and served with the utf-8 header) but shows up as ????'s within select options. It shows up correctly otherwise. Other Western and non-Western scripts show up ok within the select options (e.g., Arabic, Farsi, French, Spanish), it seems to be just Russian.

Reproducible: Always

Steps to Reproduce:
1. Add Russian text to a select option (I also have dir="ltr" and xml:lang="ru" set)

Actual Results:  
Question marks show up.

Expected Results:  
Actual Russian characters

Comment 1

11 years ago
Can you attach a minimized testcase or link to one on your server?
(Reporter)

Comment 2

11 years ago
Created attachment 237497 [details]
UTF-8 problem with Russian in a select option
(Reporter)

Comment 3

11 years ago
Created attachment 237498 [details]
UTF-8 problem with Russian in a select option

Trying auto-detect to see if XHTML can be accepted

Comment 4

11 years ago
Ah, right. I should've realized this before. You just don't have the fonts to display those characters. See http://docs.info.apple.com/article.html?artnum=301033 for more info.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

11 years ago
Ok, thanks, but it wouls seem strange that the characters do show up in Safari, no?

Comment 6

11 years ago
Hrm... yeah. Can you test in Firefox 2 beta 2 and see if you can reproduce?
(Reporter)

Comment 7

11 years ago
It also occurs in Firefox 2 beta 2, unfortunately. Yet another reason I think this is a bug and not a font issue is because the Russian UTF-8 text shows up fine for Firefox if it is outside of a drop-down menu...

Comment 8

11 years ago
OK, reopening.
Status: RESOLVED → UNCONFIRMED
Component: General → Layout
Keywords: qawanted
Product: Firefox → Core
Resolution: INVALID → ---
Version: unspecified → 1.8 Branch
QA Contact: general → layout

Comment 9

11 years ago
Both test cases work fine for me on my Mac OS 10.4.x. Brett, did you install "Mac Russian fonts" (comment #4) as opposed to "Windows" fonts? Both should just work (Safari doesn't have this problem), but currently firefox (still relying on old QuickDraw APIs) has some trouble with truetype fonts without cmap tables for old Mac encodings (e.g. Mac Cyrillic). And, this behavior may show up only in a certain case (like 'select' list). 

This might be one of many bugs that would have been fixed if the patch for bug 121540 had been landed in 1.8 branch. To check that, you may download and try Yamashita-san's build (mentioned in bug 121540 comment 267)


(Reporter)

Comment 10

11 years ago
Sorry for the delay in responding. I am using 10.4.7 and I installed the equivalent additional fonts package (in disc 1 of the DVD for 10.4), restarted just in case, and I am still having the issue in Firefox (whether Firefox 2 beta 2 or 1.5). 

Is it possible that my installation of Microsoft Office fonts could be interfering? This caused a problem earlier in my use of Safari (with Farsi), for which I had to delete 2 Office fonts to get it to work. Is there maybe anyone else who could confirm this happens on their Mac?

Comment 11

11 years ago
(In reply to comment #10)

> Is it possible that my installation of Microsoft Office fonts could be
> interfering? 

It's possible. Can you try a build by Yamashita-san at 

http://www.ms.u-tokyo.ac.jp/~makotoy/ffmath/firefox-2.0b2.en-US.mac.dmg to see if the problem goes away with it? 

(Reporter)

Comment 12

11 years ago
Yeah, that build does the trick... It's good to know so I can refer others. I'm not really using it myself--it is part of an automated localized system, but again, it's good to know. Thanks for all the help, Brett.
Brett, if you're still reading this: Do you still see this bug in a current Firefox 8 build?
(Reporter)

Comment 14

6 years ago
Nope, it's all good now, thanks!  (If I can ask, I've noticed a lot of activity on old bugs--is there a particularly good amount of headway being made or just coincidence?)
WORKSFORME per comment #14.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.