HTML anchors not working

RESOLVED DUPLICATE of bug 179940

Status

()

RESOLVED DUPLICATE of bug 179940
13 years ago
13 years ago

People

(Reporter: zenohockey, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

The HTML anchors at the URL above aren't working in FX.  It's a text-footnote setup, so when you click on, say, "[FN43]" in the body of the article, it should jump to the matching footnote towards the bottom of the page.

Reproducible: Didn't try

Steps to Reproduce:
1. Go to page above.
2. Click on, e.g., "[FNa1]."
Actual Results:  
Nothing happens.

Expected Results:  
Jump down to anchor "#Document1zzFN_Fa1."

Works perfectly in IE 6.0.

Comment 1

13 years ago
The anchors on the page given are not implemented correctly.  Only the links should have the pound (#) symbols in them.  The anchors should not have a pound symbol.

e.g.
<a name="#Document0zzSDUNumber1">
should be
<a name="Document0zzSDUNumber1">

http://www.w3.org/TR/html4/struct/links.html#h-12.1

*** This bug has been marked as a duplicate of 179940 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

13 years ago
I see... but as you can see from my example page, this is apparently how Westlaw formats pages.  Shouldn't Firefox work even with incorrect syntax where the intention is clear, as in this case?
You need to log in before you can comment on or make changes to this bug.