Closed Bug 352215 Opened 14 years ago Closed 13 years ago

rv used uninitialized in @ refChildCB, accChild should be checked first

Categories

(Core :: Disability Access APIs, defect, minor)

x86
Linux
defect
Not set
minor

Tracking

()

VERIFIED DUPLICATE of bug 386235

People

(Reporter: timeless, Assigned: timeless)

References

(Blocks 2 open bugs, )

Details

(Keywords: coverity)

Attachments

(1 file)

 
Blocks: keya11y
Attached patch swap checksSplinter Review
Assignee: aaronleventhal → timeless
Status: NEW → ASSIGNED
Attachment #238876 - Flags: review?(aaronleventhal)
Attachment #238876 - Flags: review?(aaronleventhal) → review+
Attachment #238876 - Flags: superreview?(bzbarsky)
Comment on attachment 238876 [details] [diff] [review]
swap checks

I'm kinda swamped right now... please ask someone else for sr?
Attachment #238876 - Flags: superreview?(bzbarsky)
Attachment #238876 - Flags: superreview?(cbiesinger)
I don't really like this... why not make sure that rv is always initialized, by assigning the return value of the QueryInterface call above to it?
Attachment #238876 - Flags: superreview?(cbiesinger) → superreview-
rv is not really necessary here, I'll remove it in Bug 386235.
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 386235
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.