Last Comment Bug 352240 - set up tinderboxes to run TUnit
: set up tinderboxes to run TUnit
Status: RESOLVED FIXED
:
Product: Release Engineering
Classification: Other
Component: Other (show other bugs)
: other
: All All
: -- major (vote)
: ---
Assigned To: Chris Cooper [:coop]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-11 15:52 PDT by Dave Liebreich [:davel]
Modified: 2013-08-12 21:54 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Dave Liebreich [:davel] 2006-09-11 15:52:32 PDT
Short term, I think we need dedicated tinderboxes to run the TUnit tests.  What do I need to do to escalate this to a high-enough priority so that it gets done in the next week or so?

We'd need windows, linux, and mac, in that priority order.  Each box would need to continuously build trunk with a modified mozconfig (to enable tests and disable static), and report the results to the tinderbox server such that developers would know if the tests fail.

Longer term, these build boxes would run additional tests even after we move the TUnit tests back to the regular tinderboxes.
Comment 1 Chris Cooper [:coop] 2006-10-25 20:08:07 PDT
I've setup a Windows build for this on fxexp-win32-tbox. It should begin reporting  to the MozillaExperimental tinderbox tree shortly.
Comment 2 Dave Liebreich [:davel] 2006-10-25 20:29:09 PDT
coop, is the mozconfig in the public cvs?
Comment 3 Chris Cooper [:coop] 2006-10-25 20:35:26 PDT
(In reply to comment #2)
> coop, is the mozconfig in the public cvs?

Not yet, but since I'm signed up to do bug 337362 too, it will be soon. BTW, you'll be able to see the mozconfig at the head of the tinderbox log in case there are any problems with it the meantime. 

Essentially, I just copied over the existing trunk cairo mozconfig and changed it to run with --enable-tests and --disable-static (and commented out the update-packaging stuff).

Comment 4 Dave Liebreich [:davel] 2006-10-26 09:27:16 PDT
latest log from that box shows

"Skipping Mozilla tests."

at the end.  Did you set $RunUnitTests to 1 in the tinderconfig?

Comment 5 Chris Cooper [:coop] 2006-10-26 10:16:30 PDT
(In reply to comment #4)
> at the end.  Did you set $RunUnitTests to 1 in the tinderconfig?

Any other undocumented things I should be adding/changing to these config files while I'm at it?
Comment 6 Adam Guthrie 2006-10-26 10:53:06 PDT
As I mentioned to coop on IRC, I think the problem is that $RunMozillaTests isn't set. http://lxr.mozilla.org/mozilla/source/tools/tinderbox/build-seamonkey-util.pl#1185
Comment 7 Chris Cooper [:coop] 2007-02-01 06:17:46 PST
It's not dedicated to TUnit, but sea-linux-tbox in now running TUnit instead of lhasa. Reports are going to http://tinderbox.mozilla.org/showbuilds.cgi?tree=SeaMonkey
Comment 8 Rob Campbell [:rc] (:robcee) 2007-02-01 14:02:04 PST
We've also got tests going to MozillaTest from the new VMs IT setup last week.

http://tinderbox.mozilla.org/showbuilds.cgi?tree=MozillaTest.

We're planning on moving these someplace more permanent once I've got the buildbots configured properly. Not sure where yet, but...

Note You need to log in before you can comment on or make changes to this bug.