"Feed Preferences..." menu item does not activate General prefs pane

RESOLVED FIXED in Camino1.5

Status

Camino Graveyard
Preferences
--
minor
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Chris Lawson (gone), Assigned: Sean Murphy)

Tracking

({fixed1.8.1})

Trunk
Camino1.5
PowerPC
Mac OS X
fixed1.8.1

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Summary pretty much says it all. This menu item should activate the General prefs pane, since that's where the only RSS-related pref lives.

This works fine on first launch, so to reproduce, you need to have previously opened prefs and selected something besides the General pane.
In case it's any help, the old popup blocker's menu item to "configure pop-up blocking" worked correctly.
(Assignee)

Comment 2

11 years ago
Created attachment 239447 [details] [diff] [review]
BrowserWindowController.mm: Open Feed Preferences Patch

The preference window is opened to a specific panel using an identifier (belonging to the bundle).  The feed preferences are located in the first pane, which has an identifier of org.mozilla.camino.preference.navigation.  The bug was occurring because the openFeedPrefPane: method was using org.mozilla.camino.preference.general as that identifier.

I'm betting the first panel was originally titled 'navigation', but has since been changed to 'general' (in the interface that is - the bundle identifier has always been navigation).

Comment 3

11 years ago
Comment on attachment 239447 [details] [diff] [review]
BrowserWindowController.mm: Open Feed Preferences Patch

r=me
Attachment #239447 - Flags: review+

Updated

11 years ago
Attachment #239447 - Flags: superreview?(mikepinkerton)

Updated

11 years ago
Assignee: nobody → camino
Comment on attachment 239447 [details] [diff] [review]
BrowserWindowController.mm: Open Feed Preferences Patch

sr=pink
Attachment #239447 - Flags: superreview?(mikepinkerton) → superreview+

Comment 5

11 years ago
Checked into trunk and MOZILLA_1_8_BRANCH.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.