The default bug view has changed. See this FAQ.

[SessionStore] Exception when History menu clicked while SessionStore disabled

RESOLVED DUPLICATE of bug 345898

Status

()

Firefox
Session Restore
RESOLVED DUPLICATE of bug 345898
11 years ago
10 years ago

People

(Reporter: IU, Unassigned)

Tracking

2.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060913 BonEcho/2.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060913 BonEcho/2.0b2

If you click the History menu when using the Session Manager extension (0.4.3), the following JavaScript exception is thrown:

Error: '[JavaScript Error: "this._windows[aWindow.__SSi] has no properties" {file: "file:///C:/Program%20Files/Bon%20Echo/components/nsSessionStore.js" line: 648}]' when calling method: [nsISessionStore::getClosedTabCount] = NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS
Source file: chrome://browser/content/browser.js
Line: 6333


Reproducible: Always

Steps to Reproduce:
1. Install Session Manager 0.4.3 extension and restart
2. Open Error Console
3. Click History menu and note the exception

Actual Results:  
Aforementioned JavaScript exception is thrown.
(Reporter)

Updated

11 years ago
Version: unspecified → 2.0 Branch

Comment 1

11 years ago
Note that you can replace step 1 above with:
1. Set the boolean pref browser.sessionstore.enabled to false.

The reason for the error is a missing check for whether SessionStore is actually enabled. The question is however: should callers have to check this (may lead to much duplicate code) or should getClosedTabCount et al. simply return 0/null/whatever instead of throwing? I'd favor the latter...

See also bug 345898 which is about making this error message more informative.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Summary: JavaScript Exception if History menu clicked when Session Manager extension is installed → [SessionStore] Exception when History menu clicked while SessionStore disabled
Patch in bug 345898 fixes this.
Depends on: 345898
Component: History → Session Restore
QA Contact: history → session.restore
(Reporter)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Comment 3

10 years ago
Still happens on the latest Trunk nightlies, so not WORKSFORME but at best a DUPE.
No longer depends on: 345898
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 345898
You need to log in before you can comment on or make changes to this bug.