Thunderbird crashes when marking message as junk while viewing the message [@ nsXPCWrappedJS::`vftable' - nsMsgDBFolder::NotifyFolderEvent]

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
12 years ago
7 years ago

People

(Reporter: frank, Assigned: Bienvenu)

Tracking

({crash})

1.8 Branch
x86
Windows XP
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs trunk test], crash signature)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Thunderbird/1.5.0.7

When I am reading unread messages in my inbox in a window (as in, not in a pane and not just looking at the list of messages), and I mark the LAST one in my inbox as "junk," Thunderbird crashes and quits and the Quality Feedback Agent pops up (although I have never been able to get it to actually connect to anything).  I have the same version of Thunderbird installed on two computers - this was reproducible always under Thunderbird 1.5.0.5 on my other computer (which runs Windows Server 2003) but not this one.  Now that I've upgraded to 1.5.0.7, it happens on both computers.

Reproducible: Always

Steps to Reproduce:
1. Check for new mail.
2. Receive new mail, at least some of which is spam that didn't get marked as junk by the filter for one reason or another.
3. Open a message to look at the body, just to make sure it really IS spam.
4. Conclude it is spam, click the "junk" icon to mark it as junk.
5. Thunderbird automatically moves to the next message.  Alternatively, if the message was not junk, type "N" on the keyboard to move to the next message.  Repeat as needed.
6.  If the LAST message in the inbox is spam, and you click the "junk" icon, Thunderbird immediately crashes, closes, and brings up both the Quality Feedback Agent and Microsoft's error reporting thing.
7.  This does NOT happen if you mark the message as junk while just looking at the list-view of the inbox.

Actual Results:  
Thunderbird crashes.  Also, the junk folder (or maybe the junk log?) gets corrupted, with all the previous junk messages now showing question marks instead of the little "junk or not junk" icon.

Expected Results:  
Mark the message as junk and move it to the junk folder.

I am using the default theme, for whatever that's worth.  I don't think my computer is particularly specially set up, although I regularly scan it for viruses and malware using several different programs, and I have a firewall.
(Reporter)

Comment 1

12 years ago
Oh.  I forgot.  On my Windows 2003 system, I get the slightly more helpful error message "The instruction at [some apparently random number that keeps changing] referenced memory at "0x00000000".  The memory could not be "read"."  I am then invited to click "OK" to terminate or "CANCEL" to debug, but both options pretty much seem to do the same thing and simply terminate the program.  I have run extensive memory checking to ensure that it's not a hardware error in the RAM.  (Sorry for forgetting to put this in the first message.)

Comment 2

12 years ago
Please install a build with Talkback and get a Talkback ID for the crash. http://kb.mozillazine.org/Talkback
(Reporter)

Comment 3

12 years ago
Talkback IS installed.  In fact, I always install builds with Talkback.  I am not sure if the "Build Identifier" box should reflect that, I entered that manually because I couldn't figure out from where to copy that data out of the application itself.

Anyway, I am not sure if by "Talkback ID" you mean whatever goes in the "Incident ID" column in the Mozilla Quality Feedback Agent program, but I presume you do.  It won't give me a Talkback ID, which I further presume is because it can't connect to the server or something.  It tells me to check my proxy settings - which I don't have.  This error occurs consistently on both my machines, and given the number-one question at the FAQ:

http://wiki.mozilla.org/Mozilla_QA_Community:Talkback:FAQ

...I am apparently not alone in this particular problem.  For what it's worth, I'm on either a high-speed LAN or high-speed DSL, all with quite fat pipes to the internet.  The official line seems to be that this error message is misleading, but I usually try sending it a few times before giving up.  I have yet to see it generate anything in the "Incident ID" column.  I'll try again, though, the next time this happens.
(Reporter)

Comment 4

12 years ago
Nope, "The Agent is unable to connect to the server."  Still.  And I don't see any incident ID being generated.  However, because the report is apparently sitting in the queue, it is presumably being stored in a data file somewhere on my hard drive and therefore can be manually located and copied, surely?  If someone knows how to do that, I'd be happy to attach a copy of that file.

Comment 5

12 years ago
Nope. It has to be processed by the server to be useful, actually.
(Reporter)

Comment 6

12 years ago
Is there a way to transmit the data package to/through someone who IS able to feed it to the server?

Comment 7

12 years ago
Maybe, but it's probably more trouble than it's worth. You could try zipping up your profile and trying to reproduce on another machine whose connection isn't bonk. Also, lots of crash bugs have been fixed in Thunderbird 2 alpha 1. You could test with it (back up your profile first) and see if it's fixed. http://kb.mozillazine.org/Profile

Updated

12 years ago
Severity: normal → critical
Keywords: crash
Version: unspecified → 1.5

Comment 8

12 years ago
My OS is Linux(Fedora Core 5). Same problem.

Comment 9

11 years ago
Shayin, do you have a talkback id?
Frank, do you see this in version 2?
(Reporter)

Comment 10

11 years ago
I had gotten so used to working around this problem that I simply hadn't checked since upgrading to version 2.  So I just tried, and yes, I do still see this.  However, Talkback actually worked this time.  Talkback tells me that the "incident ID" is TB35509331G.  Thank you, and I hope that helps.

Comment 11

11 years ago
Incident ID: 35509331
Stack Signature	nsXPCWrappedJS::`vftable' d4939352
Product ID	Thunderbird2
Build ID	2007072817
Trigger Time	2007-09-01 23:17:14.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	thunderbird.exe + (00639a13)
URL visited	
User Comments	Marking the last unread message in my inbox as "junk" while viewing that message. See Bug Number 352814.
Since Last Crash	310166 sec
Total Uptime	310166 sec
Trigger Reason	Access violation
Source File, Line No.	N/A
Stack Trace 	
nsXPCWrappedJS::`vftable'
nsMsgDBFolder::NotifyFolderEvent  [mozilla/mailnews/base/util/nsMsgDBFolder.cpp, line 4777]
nsMsgLocalMailFolder::EndMove  [mozilla/mailnews/local/src/nsLocalMailFolder.cpp, line 2847]
nsCopyMessageStreamListener::EndCopy  [mozilla/mailnews/base/src/nsCopyMessageStreamListener.cpp, line 183]
nsCopyMessageStreamListener::OnStopRequest  [mozilla/mailnews/base/src/nsCopyMessageStreamListener.cpp, line 195]
nsMailboxProtocol::OnStopRequest  [mozilla/mailnews/local/src/nsMailboxProtocol.cpp, line 395]
nsInputStreamPump::OnStateStop  [mozilla/netwerk/base/src/nsInputStreamPump.cpp, line 564]
0x02ce0de0
nsMailboxProtocol::`vftable'
nsMsgProgress::AddRef  [mozilla/mailnews/base/src/nsMsgProgress.cpp, line 49]
0x8b560c45
Assignee: mscott → bienvenu
Component: General → MailNews: Database
Product: Thunderbird → Core
QA Contact: general → database
Summary: Thunderbird crashes when marking message as junk while viewing the message → Thunderbird crashes when marking message as junk while viewing the message [@ nsXPCWrappedJS::`vftable' - nsMsgDBFolder::NotifyFolderEvent]
Version: 1.5 → 1.8 Branch
(Assignee)

Comment 12

11 years ago
not sure what this has to do with the mail database...is there some part of the stack I'm missing? Perhaps there's a bad listener, registered from js, that didn't unregister itself when it went away.
Status: UNCONFIRMED → NEW
Component: MailNews: Database → MailNews: Backend
Ever confirmed: true

Comment 13

11 years ago
I read <nsMsgDBFolder> as Database, if it means something else, I'm sorry.
Assignee: bienvenu → nobody
QA Contact: database → backend

Updated

11 years ago
Assignee: nobody → bienvenu
(Assignee)

Comment 14

11 years ago
nah, it just means a folder that has a msg database behind it (which turns out to be all folders, but the original design was for folders to be able to contain other things as well).

Comment 15

11 years ago
"not my fault" :), I always thought it was strange but never cared enough.
Product: Core → MailNews Core

Comment 16

10 years ago
Frank, can you try the recent beta and see if it has the same problem?
http://www.mozillamessaging.com/en-US/thunderbird/early_releases/
backup your profile first

(this top of stack is indeed rare, it's not in the top 100)

Updated

9 years ago
Whiteboard: [needs trunk test

Comment 17

9 years ago
I'm going to call ths WFM - no stacks on crash-stats that match.
If you can reproduce this with a beta or trunk build please reopen the bug
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Whiteboard: [needs trunk test → [needs trunk test]
Crash Signature: [@ nsXPCWrappedJS::`vftable' - nsMsgDBFolder::NotifyFolderEvent]
You need to log in before you can comment on or make changes to this bug.