Add size definition for <tt> in platformClasses.css in SeaMonkey help

RESOLVED FIXED

Status

RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: lemiel, Assigned: prometeo.bugs)

Tracking

({fixed-seamonkey1.1b})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; pl-PL; rv:1.8.0.7) Gecko/20060910 SeaMonkey/1.0.5 Mnenhy/0.7.4.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; pl-PL; rv:1.8.0.7) Gecko/20060910 SeaMonkey/1.0.5 Mnenhy/0.7.4.0

Proposed change (not from CVS, from SeaMonkey 1.1 zip version) for better readability of teletype fonts in SeaMonkey help.

--- helpFileLayout.css	2004-10-28 04:11:28.000000000 +0200
+++ helpFileLayout.css	2006-09-16 13:40:48.000000000 +0200
@@ -36,24 +36,25 @@
 @import url("chrome://help/content/platformClasses.css");
 
 body {
 	margin: 2ex;
 	color: black;
 	font-family: sans-serif;
 	font-size: 0.75em;
 	max-width: 120ex;
 }
 
 dd { margin-left: 0px; margin-bottom: 1em; }
 dt { font-size: 10pt; font-weight: bold; }
+tt { font-size: 10pt; }
 
 :link:hover { color: red; }
 
 h1 { font-size: 20pt; }
 h2 { border-top: 1px solid black; font-size: 16pt; padding-top: 0.2em; }
 h3 { color: #009; font-size: 10pt; margin-bottom: 0px; margin-top: 35px; }
 
 kbd { font-family: sans-serif; }
 
 table.defaultTable { border-collapse: collapse; border: 1px solid grey;
   width: 100%; }
 


Reproducible: Always

Actual Results:  
To small teletype fonts. Bad readability.

Expected Results:  
Set size of teletype fonts. With good readability.
(Assignee)

Comment 1

12 years ago
Created attachment 241312 [details] [diff] [review]
As a patch...
(Assignee)

Comment 2

12 years ago
With this patch, <tt>s are much more readable with my linux build (FC5, standard theme and font/screen settings). What about other platforms? Seems a good addition...
(Reporter)

Comment 3

12 years ago
I add it because of request from users on our forum and because it was really to small.
On windows is good readability to.
I did not make patch because do not know how.
Sorry Giacomo for not cc-ing you after adding it.

(Assignee)

Comment 4

12 years ago
(In reply to comment #3)
> Sorry Giacomo for not cc-ing you after adding it.

Np. Now, if we can find some mac user to confirm it looks good there too... :)

Comment 5

12 years ago
It might be better to use em instead of pt. I was playing with this  for 1-2 years ago (there was a bug about it that was made invalid iirc). Anyway, I recall that something like 1.2em looked good. I also think that we should get rid of all the hard-coded font-sizes (not in this bug, though)
Assignee: neil → giacomo.magnini
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 6

12 years ago
Created attachment 241708 [details] [diff] [review]
Following stefanh's suggestion.
Attachment #241312 - Attachment is obsolete: true
Attachment #241708 - Flags: review?(iann_bugzilla)

Comment 7

12 years ago
Comment on attachment 241708 [details] [diff] [review]
Following stefanh's suggestion.

r=me as long as you get the change tested on mac, windows, linux and os/2
Attachment #241708 - Flags: review?(iann_bugzilla) → review+
Comment on attachment 241708 [details] [diff] [review]
Following stefanh's suggestion.

Please don't use em units for font size. Since em units are measured in terms of the font size, what you have in fact written is font-size: 120%; and I don't think that's what you want.
(Assignee)

Comment 9

12 years ago
Stefan: since Neil doesn't like the idea of em, can you please confirm that using the previous patch does actually improve the readability of the docs under mac?
That patch seems to improve things on win, linux and os/2, so it would be better than nothing...

Ian: if Stefan gives his ok, can you please check in the old patch instead?
TIA, Giacomo.

Comment 10

12 years ago
(In reply to comment #9)
> Stefan: since Neil doesn't like the idea of em, can you please confirm that
> using the previous patch does actually improve the readability of the docs
> under mac?

Yeah, it does.
(Assignee)

Updated

12 years ago
Attachment #241312 - Attachment is obsolete: false
Attachment #241312 - Flags: review+
Attachment #241312 - Flags: approval-seamonkey1.1b?
(Assignee)

Comment 11

12 years ago
Comment on attachment 241708 [details] [diff] [review]
Following stefanh's suggestion.

Moving r+ to the other patch, based upon Neil's comment
Attachment #241708 - Attachment is obsolete: true

Comment 12

12 years ago
Comment on attachment 241312 [details] [diff] [review]
As a patch...

a=me for 1.1b
Attachment #241312 - Flags: approval-seamonkey1.1b? → approval-seamonkey1.1b+
(Assignee)

Updated

12 years ago
Whiteboard: [checkin needed]
Fix checked in branch and trunk.
Status: NEW → ASSIGNED
Keywords: fixed-seamonkey1.1b
Whiteboard: [checkin needed]
(Assignee)

Updated

12 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.