Section about preparing good password in SeaMonkey help

RESOLVED FIXED

Status

SeaMonkey
Help Documentation
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Rafal Likus, Assigned: Giacomo Magnini)

Tracking

({fixed-seamonkey1.1b})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; pl-PL; rv:1.8.0.7) Gecko/20060910 SeaMonkey/1.0.5 Mnenhy/0.7.4.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; pl-PL; rv:1.8.0.7) Gecko/20060910 SeaMonkey/1.0.5 Mnenhy/0.7.4.0

Not from CVS, from SeaMonkey 1.1 zip version:

--- using_priv_help.xhtml	2006-01-24 11:11:26.000000000 +0100
+++ using_priv_help.xhtml	2006-09-16 21:10:14.000000000 +0200
@@ -1382,24 +1382,25 @@
 
 <div class="contentsBox">In this section:
   <ul>
     <li><a href="#turning_encryption_on_and_off">Turning Encryption On and
       Off</a></li>
     <li><a href="#setting_a_master_password">Setting a Master Password</a></li>
     <li><a href="#changing_your_master_password">Changing Your Master
       Password</a></li>
     <li><a href="#logging_out_of_your_master_password">Logging Out of Your
       Master Password</a></li>
     <li><a href="#what_to_do_if_you_forget_your_master_password">What to Do If
       You Forget Your Master Password</a></li>
+    <li><a href="#choosing_a_good_password">Choosing a Good Passwords</a></li>
   </ul>
 </div>
 
 <h2 id="turning_encryption_on_and_off">Turning Encryption On and Off</h2>
 
 <p>To turn on encryption for your stored sensitive information:</p>
 
 <ol>
   <li>Open the <span class="mac">&brandShortName;</span>
     <span class="noMac">Edit</span> menu and choose Preferences.</li>
   <li>Under the Privacy &amp; Security category, click Passwords. (If no
     subcategories are visible, double-click Privacy &amp; Security to expand
@@ -1437,53 +1438,50 @@
     <span class="noMac">Edit</span> menu and choose Preferences.</li>
   <li>Under the Privacy &amp; Security category, click Master Passwords. (If no
     subcategories are visible, double-click Privacy &amp; Security to expand
     the list.)</li>
   <li>In the Change Master Password section, click Change Password... to open
     the Change Master Password dialog box.</li>
   <li>Enter your desired master password, and retype it to confirm the
     spelling.</li>
   <li>Click OK.</li>
 </ol>
 
 <p>Make sure your new password is difficult to guess. For some suggestions on
-  how to improve password security, see the online document
-  <a href="http://browser.netscape.com/ns8/security/tips_password.jsp">Choosing
-  a Good Password</a>.</p>
+  how to improve password security, see
+  <a href="#choosing_a_good_password">Choosing a Good Passwords</a>.</p>
 
 <p>[<a href="#encrypting_stored_sensitive_information">Return to beginning of
   section</a>]</p>
 
 <h2 id="changing_your_master_password">Changing Your Master Password</h2>
 
 <p>To change your master password:</p>
 
 <ol>
   <li>Open the <span class="mac">&brandShortName;</span>
     <span class="noMac">Edit</span> menu and choose Preferences.</li> 
   <li>Under the Privacy &amp; Security category, click Master Passwords. (If no
     subcategories are visible, double-click Privacy &amp; Security to expand
     the list.)</li>
   <li>In the Change Master Password section, click Change Password... to open
     the Change Master Password dialog box.</li>
   <li>Enter your current master password.</li>
   <li>Enter your new master password, and retype it to confirm the
     spelling.</li>
   <li>Click OK.</li>
 </ol>
 
 <p>Make sure your new password is difficult to guess. For some guidelines, see
-  the online document
-  <a href="http://browser.netscape.com/ns8/security/tips_password.jsp">Choosing
-  a Good Password</a>.</p>
+  <a href="#choosing_a_good_password">Choosing a Good Passwords</a>.</p>
 
 <p>[<a href="#encrypting_stored_sensitive_information">Return to beginning of
   section</a>]</p>
 
 <h2 id="logging_out_of_your_master_password">Logging Out of Your Master
   Password</h2>
 
 <p>Normally, you are asked for your master password once during each
   &brandShortName; session during which you access any of your stored sensitive
   information.</p>
 
 <p>It&apos;s also possible to require that your master password be requested
@@ -1533,24 +1531,62 @@
 <ol>
   <li>Open the <span class="mac">&brandShortName;</span>
     <span class="noMac">Edit</span> menu and choose Preferences.</li>
   <li>Under the Privacy &amp; Security category, click Master Passwords. (If no
     subcategories are visible, double-click Privacy &amp; Security to expand
     the list.)</li>
   <li>Click Reset Master Password.</li>
   <li>In the Reset Master Password dialog box, click Reset.</li>
 </ol>
 
 <p>[<a href="#encrypting_stored_sensitive_information">Return to beginning of
   section</a>]</p>
+<h2 id="choosing_a_good_password">Choosing a Good Passwords</h2>
+
+<p>Based on Netscape website <a
+  href="http://browser.netscape.com/ns8/security/tips_password.jsp">Choosing
+  Passwords</a>.</p>
+
+<p>Don't Use:</p>
+
+<ul>
+  <li>Any part of your name - first, last, or middle</li>
+  <li>Your initials</li>
+  <li>Your social security number</li>
+  <li>Names of friends, family, or pets</li>
+  <li>Birthdays</li>
+  <li>Phone numbers or addresses</li>
+  <li>Any other personal information that could be guessed</li>
+  <li>Place names</li>
+  <li>Words from the English dictionary</li>
+  <li>Words from a foreign dictionary</li>
+  <li>Your username or login name</li>
+  <li>Your computer's name</li>
+  <li>Repetition of the same letter</li>
+  <li>Sequences of keyboard keys, such as "12345" or "qwerty"</li>
+  <li>Any minor variation of the above, such as spelling backwards or appending a character to the end of your name</li>
+</ul>
+
+<p>Do Use:</p>
+
+<ul>
+  <li>Special characters (*!$+) mixed with letters and numbers</li>
+  <li>Mixed upper- and lower-case letters - putting capitals in random locations throughout a password is effective</li>
+  <li>Punctuation characters mixed with letters and numbers</li>
+  <li>Nonsense words that are easy to pronounce but aren't in any dictionary</li>
+  <li>Six or more characters</li>
+</ul>
+
+<p>[<a href="#encrypting_stored_sensitive_information">Return to beginning of
+  section</a>]</p>
 
 <h1 id="managing_images">Managing Images</h1>
 
 <p>If you wish, you can choose not to download any images when you browse the
   web. This greatly restricts what you can view online, but may be helpful if
   you have a slow connection and wish to shorten the time it takes web pages to
   load.</p>
 
 <p>You can also control how frequently animated images repeat their animation,
   or turn off animation completely.</p>
 
 <p>The next section describes how to control these image settings. The default


Reproducible: Always




Do not know if it could be just as it is.
(Assignee)

Comment 1

11 years ago
Created attachment 241310 [details] [diff] [review]
More complete approach, including changes to toc, index1 and other links
(Assignee)

Updated

11 years ago
Attachment #241310 - Flags: review?(iann_bugzilla)
(Assignee)

Updated

11 years ago
Flags: blocking-seamonkey1.1b?

Comment 2

11 years ago
Comment on attachment 241310 [details] [diff] [review]
More complete approach, including changes to toc, index1 and other links

>Index: extensions/help/resources/locale/en-US/passwords_help.xhtml
>===================================================================
>@@ -418,6 +417,54 @@
>   the master password for a smart card (assuming that you remember it), but you
>   cannot reset it.</p>
> 
>+<h2 id="choosing_a_good_password">Choosing a Good Password</h2>
>+
>+<p>Choosing a good password will help in keeping your personal information
>+  safe and private. To improve the security of your password, follow some
>+  or all of these suggestions:</p>
>+
>+<ul>
>+  <li>Special and punctuation characters (*!$+) mixed with letters and
>+    numbers</li>
>+  <li>Mixed upper- and lower-case letters - putting capitals in random
I'm not happy with "upper-" should be either "upper-case" or "upper".

>+    locations throughout a password is effective</li>
>+  <li>Nonsense words that aren't found in dictionaries but are easy to
Do we use ' now? (and in other places)

>+    pronounce</li>
>+  <li>Eight or more characters</li>
>+</ul>
>+
>+<p>You should avoid personal informations that could be guessed. So the
Remove the s: informations -> information
>+  following common items should be avoided:</p>

Only need to patch /suite on trunk I think now. r=me with those fixed.
Attachment #241310 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Comment 3

11 years ago
Created attachment 242186 [details] [diff] [review]
Updated patch, with fixed review comments (Checked into trunk & 1.8.1 branch)

Can someone please check this in?
Attachment #241310 - Attachment is obsolete: true
Attachment #242186 - Flags: review+

Comment 4

11 years ago
Comment on attachment 242186 [details] [diff] [review]
Updated patch, with fixed review comments (Checked into trunk & 1.8.1 branch)

I assume you want this for 1.1b since you've asked for blocking... ;-)
Attachment #242186 - Flags: approval-seamonkey1.1b?

Comment 5

11 years ago
Comment on attachment 242186 [details] [diff] [review]
Updated patch, with fixed review comments (Checked into trunk & 1.8.1 branch)

thanks a=me for 1.1b
Attachment #242186 - Flags: approval-seamonkey1.1b? → approval-seamonkey1.1b+

Updated

11 years ago
Assignee: neil → giacomo.magnini
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [checkin needed]

Comment 6

11 years ago
Comment on attachment 242186 [details] [diff] [review]
Updated patch, with fixed review comments (Checked into trunk & 1.8.1 branch)

Checking in (trunk)
certs_help.xhtml;
new revision: 1.49; previous revision: 1.48
help-index1.rdf;
new revision: 1.55; previous revision: 1.54
passwords_help.xhtml;
new revision: 1.44; previous revision: 1.43
using_priv_help.xhtml;
new revision: 1.62; previous revision: 1.61
done
Checking in (1.8.1 branch)
certs_help.xhtml;
new revision: 1.45.8.3; previous revision: 1.45.8.2
help-index1.rdf;
new revision: 1.44.8.9; previous revision: 1.44.8.8
passwords_help.xhtml;
new revision: 1.40.8.3; previous revision: 1.40.8.2
using_priv_help.xhtml;
new revision: 1.56.6.5; previous revision: 1.56.6.4
done
Attachment #242186 - Attachment description: Updated patch, with fixed review comments → Updated patch, with fixed review comments (Checked into trunk & 1.8.1 branch)

Comment 7

11 years ago
Do we need any changes to suite-toc.rdf / help-toc.rdf?
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Keywords: fixed-seamonkey1.1b, fixed1.8.1
Resolution: --- → FIXED
Whiteboard: [checkin needed]

Updated

11 years ago
Flags: blocking-seamonkey1.1b?

Comment 8

11 years ago
(In reply to comment #7)
> Do we need any changes to suite-toc.rdf / help-toc.rdf?
> 

Hmm, it looks like the patch in bug 273619 added "Choosing a Good Password" to the toc files.

Comment 9

11 years ago
Comment on attachment 242186 [details] [diff] [review]
Updated patch, with fixed review comments (Checked into trunk & 1.8.1 branch)

+  <li>Mixed upper and lower-case letters - putting capitals in random
+    locations throughout a password is effective</li>

Nit: should be &mdash; instead of "-".

Comment 10

11 years ago
Created attachment 242352 [details] [diff] [review]
Fix nit
Attachment #242352 - Flags: review?(iann_bugzilla)

Comment 11

11 years ago
Created attachment 242355 [details] [diff] [review]
More nits...(Checked into trunk & 1.8.1 branch)

There should be periods after each sentence in the lists (we have that elsewhere) ;-)
Attachment #242352 - Attachment is obsolete: true
Attachment #242355 - Flags: review?(iann_bugzilla)
Attachment #242352 - Flags: review?(iann_bugzilla)
(Assignee)

Comment 12

11 years ago
(In reply to comment #11)
> There should be periods after each sentence in the lists (we have that
> elsewhere) ;-)

Thanks for catching those, Stefan.
(Reporter)

Comment 13

11 years ago
(In reply to comment #9)
> Nit: should be &mdash; instead of "-".

But is &mdash; without spaces before and after &mdash;
Is it correct? I am not sure about typography in english.

+  <li>Mixed upper and lower-case letters&mdash;putting capitals in random
or
+  <li>Mixed upper and lower-case letters &mdash; putting capitals in random

(Assignee)

Comment 14

11 years ago
(In reply to comment #13)
> +  <li>Mixed upper and lower-case letters&mdash;putting capitals in random

This is what we use elsewhere, IIRC.

Comment 15

11 years ago
(In reply to comment #14)
> (In reply to comment #13)
> > +  <li>Mixed upper and lower-case letters&mdash;putting capitals in random
> This is what we use elsewhere, IIRC.

Yes, we already have it in the file (somewhere above the part Giacomo added).

Updated

11 years ago
Attachment #242355 - Flags: review?(iann_bugzilla) → review+

Updated

11 years ago
Attachment #242355 - Flags: approval-seamonkey1.1b+

Updated

11 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: [checkin needed] of attachment #242355 (trunk/1.8.1)
(Assignee)

Comment 16

11 years ago
Removed the keywords fixed-seamonkey1.1b, fixed1.8.1 beacause the follow up patch has not been checked into trunk and branch, and without the keywords this should show up once again on radar...
Keywords: fixed-seamonkey1.1b, fixed1.8.1

Comment 17

11 years ago
This is now checked in on trunk/branch by Mark Banner (thanks!)
Status: REOPENED → RESOLVED
Last Resolved: 11 years ago11 years ago
Keywords: fixed-seamonkey1.1b
Resolution: --- → FIXED
Whiteboard: [checkin needed] of attachment #242355 (trunk/1.8.1)

Updated

11 years ago
Attachment #242355 - Attachment description: More nits... → More nits...(Checked into trunk & 1.8.1 branch)
You need to log in before you can comment on or make changes to this bug.