Event titles do not wrap in week view (nor day view) (regression)

VERIFIED FIXED in Sunbird 0.5

Status

Calendar
Calendar Views
VERIFIED FIXED
12 years ago
11 years ago

People

(Reporter: gekacheka, Assigned: gekacheka)

Tracking

(Blocks: 1 bug, {regression})

Trunk
Sunbird 0.5
regression

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060915 Calendar/0.3a2+

Week view (and day view) wrapped titles in 0.3a2, but now fail to wrap titles.


Reproducible: Always

Steps to Reproduce:
- Create a 2hr event in 7day week view
- Give it a multiword title longer than the width of the column

(This is particularly a problem when the window is narrow, as on small screens.)

Actual Results:  
Title is cropped, leaving empty space below.
(Cropping adds "..." so less than the full width is used.)

Expected Results:  
Title is wrapped, making use of available space in event box.

[This bug is separate from bug 231486 because this bug is a regression, and bug 231486 is an enhancement which also asks for wrapping in month view as well as week view.]
(Assignee)

Updated

12 years ago
Blocks: 231486
Flags: blocking0.3?
Keywords: regression
Summary: Titles do not wrap in week view (nor day view) (regression) → Event titles do not wrap in week view (nor day view) (regression)
Version: unspecified → Trunk
(Assignee)

Comment 1

12 years ago
Created attachment 238853 [details] [diff] [review]
v1 patch mulitiday-view#calendar-event-box to wrap title

(patch -l -p 2 -i file.patch)

Changes:
1. change event-name from <label> to <description>.
2. override method setEditableLabel to set .textContent instead of .value.
3. vbox align="stretch" so text field will use full width in day view.
4. remove crop="right" on textbox (didn't do anything).
5. remove <spacer> (not needed).

Tested on w2k, wrapping is restored, editing uses full width but does not wrap (single line textbox).
Attachment #238853 - Flags: second-review?(jminta)
Attachment #238853 - Flags: first-review?(mattwillis)
Comment on attachment 238853 [details] [diff] [review]
v1 patch mulitiday-view#calendar-event-box to wrap title

Good to see you again gekacheka!

>+      <method name="setEditableLabel">
>+        <body><![CDATA[
>+          var evl = this.eventNameLabel;
>+          var item = this.mOccurrence;
>+
>+
Let's use one blank line here ^^^ rather than two 

>+          if (item.title && item.title != "") {
>+            // Use <description> textContent so it can wrap.
>+            evl.textContent = item.title;
>+          } else {
>+            evl.textContent = calGetString("calendar", "eventUntitled")
Missing a trailing semicolon here ^^^

r=lilmatt with those nits fixed

Thanks!
Attachment #238853 - Flags: first-review?(mattwillis) → first-review+

Comment 3

12 years ago
We may take this, if there is enough time left, but this is not a serious showstopper.
Assignee: nobody → gekacheka
Flags: blocking0.3? → blocking0.3-
(Assignee)

Comment 4

12 years ago
Created attachment 238877 [details] [diff] [review]
v2 patch mulitiday-view#calendar-event-box to wrap title (nits fixed)

(patch -l -p 2 -i file.patch)

(see comment #1 for description of changes)
Attachment #238853 - Attachment is obsolete: true
Attachment #238877 - Flags: second-review?(jminta)
Attachment #238853 - Flags: second-review?(jminta)
Whiteboard: [needs review jminta]

Comment 5

11 years ago
*** Bug 356483 has been marked as a duplicate of this bug. ***

Comment 6

11 years ago
Comment on attachment 238877 [details] [diff] [review]
v2 patch mulitiday-view#calendar-event-box to wrap title (nits fixed)

Looks fine.  Sorry for the delay here.  Just need mvl to sign off on the user-experience changes.
Attachment #238877 - Flags: ui-review?(mvl)
Attachment #238877 - Flags: second-review?(jminta)
Attachment #238877 - Flags: second-review+
Comment on attachment 238877 [details] [diff] [review]
v2 patch mulitiday-view#calendar-event-box to wrap title (nits fixed)

ui looks good
Attachment #238877 - Flags: ui-review?(mvl) → ui-review+
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Whiteboard: [needs review jminta]
Target Milestone: --- → Sunbird 0.5
Verified with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20061228 Calendar/0.4a1.
Status: RESOLVED → VERIFIED

Updated

11 years ago
Whiteboard: [litmus testcase wanted]

Comment 10

11 years ago
Litmus testcase 3015 created
Whiteboard: [litmus testcase wanted]
You need to log in before you can comment on or make changes to this bug.