FF crashed in JAR50.DLL with McAfee Siteadvisor extension installed

RESOLVED DUPLICATE of bug 333423

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 333423
12 years ago
12 years ago

People

(Reporter: John, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

If McAfee Siteadvisor Extension is installed this occurs: If you start in safe mode and delete SiteAdvisor the problem is corrected.
FIREFOX caused an invalid page fault in
module JAR50.DLL at 016f:6001134d.
Registers:
EAX=00ef61c0 CS=016f EIP=6001134d EFLGS=00010246
EBX=017d0003 SS=0177 ESP=00d1f148 EBP=00d1f15c
ECX=018a644c DS=0177 ESI=00ef61a0 FS=4f3f
EDX=00000003 ES=0177 EDI=018c2070 GS=0000
Bytes at CS:EIP:
ff 37 e8 ee 81 00 00 59 59 f7 d8 1b c0 40 66 81 
Stack dump:
00ef61c0 00d1f1a4 00ef6180 017d9d0a 018a644c 00d1f180 60013e4b 00ef61a0 00ef6190 00d1f354 6038a57b 00ef6180 00d1f1a4 00d1f1a4 00d1f338 00420614


Reproducible: Always

Steps to Reproduce:
1.Reinstall siteadvisor extension
2.First time after restart opens ok and siteadvisor works
3.Future attempts to start Firefox stop

Actual Results:  
Windows error message - details as stated above
Firefox will not open.

Expected Results:  
Firefox open with siteadvisor working.

Firefox working OK without extension.  The extension works OK in Internet Explorer.  Will go back to using IE with Windows 98SE as I now like browsing with McAfee SiteAdvisor. This site assessment should be built into all browsers. i also us an XP sp2 computer and the extension works there with Firefox.

Comment 1

12 years ago
Does talkback fire when you crash? If so, can you paste one of the crash IDs? http://kb.mozillazine.org/Talkback
Severity: normal → critical
Keywords: crash, stackwanted
Summary: FF caused page fault in JAR50.DLL at 016f:6001134d. → FF crashed in JAR50.DLL at 016f:6001134d

Comment 2

12 years ago
Turns out that McAfee is abusing APIs. In bug 333423 there is a patch that makes us not crash when this happens. Hopefully we can get this patch into the branch 1.5.0.x is made from.

*** This bug has been marked as a duplicate of 333423 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Keywords: stackwanted
Resolution: --- → DUPLICATE
Summary: FF crashed in JAR50.DLL at 016f:6001134d → FF crashed in JAR50.DLL with McAfee Siteadvisor extension installed
You need to log in before you can comment on or make changes to this bug.