regression: Edit->Delete and Edit->Switch Text Direction are always enabled

RESOLVED FIXED in Firefox 2

Status

()

Firefox
General
P1
major
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: mano, Assigned: mano)

Tracking

({fixed1.8.1, regression})

unspecified
Firefox 2
fixed1.8.1, regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox2 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Once "Switch Text Direction" is enabled (by focusing something-editable), it stays enabled even when elements which are not editable are focused (content area, tabs etc.). This works fine in Fx 1.5.0.x. Simon was able to reproduce this on windows too.

Other than polish, this probably leads to a confusion on what Edit->Switch Text Direction stands for, see bug 352645.
Flags: blocking-firefox2?
OS: Mac OS X 10.3 → All
Hardware: Macintosh → All
OK, this is an API regression from bug 317633, we no longer disable commands if they don't have a controller in the current context (which is the way this works since the beginning of time).
Blocks: 317633
Severity: normal → major
Priority: -- → P1
Target Milestone: --- → Firefox 2
Created attachment 238881 [details] [diff] [review]
patch

Drivers: without this fix, extensions which add command controllers are broken as well ("BiDi Mail UI" for example).
Assignee: nobody → mano
Status: NEW → ASSIGNED
Attachment #238881 - Flags: review?(mconnor)
Attachment #238881 - Flags: approval1.8.1?
Also happens with the delete menu item once text is selected in any text field.
Summary: regression: Edit->Switch Text Direction is always enabled → regression: Edit->Delete and Edit->Switch Text Direction is always enabled
Summary: regression: Edit->Delete and Edit->Switch Text Direction is always enabled → regression: Edit->Delete and Edit->Switch Text Direction are always enabled
Comment on attachment 238881 [details] [diff] [review]
patch

hmm, this is Places fallout it seems, at least we caught it I guess
Attachment #238881 - Flags: review?(mconnor)
Attachment #238881 - Flags: review+
Attachment #238881 - Flags: approval1.8.1?
Attachment #238881 - Flags: approval1.8.1+
1.8:
mozilla/toolkit/content/globalOverlay.js 1.18.8.9
Keywords: fixed1.8.1

Updated

11 years ago
Flags: blocking-firefox2? → blocking-firefox2+
trunk: mozilla/toolkit/content/globalOverlay.js 1.28
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.