problem with refreshing tasks in main view when end due starts is set

VERIFIED FIXED in Sunbird 0.5

Status

Calendar
Tasks
VERIFIED FIXED
11 years ago
10 years ago

People

(Reporter: Damian Szczepanik, Assigned: Stefan Sitter)

Tracking

({dataloss})

Trunk
Sunbird 0.5
dataloss

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060917 Calendar/0.3a2+

new task is not visible in week view when due time is set

Reproducible: Always

Steps to Reproduce:
1. switch to week view and enable "Tasks in view"
2. Go to today
3. create new task start date = today, due date is disabled
  -> task is not visible in main view - ok
4. edit created task, enable due date = start date + 1 hour
Actual Results:  
task is not visible in main view

Expected Results:  
task should be visible because if I switch to day view and go back to week task is visible so this is problem with refresing

Updated

11 years ago
Flags: blocking0.3?
Keywords: dataloss

Comment 1

11 years ago
This is unfortunate, but since it gets fixed by a refresh, relnoting should be good enough.
Flags: blocking0.3? → blocking0.3-
Keywords: relnote
Whiteboard: [cal relnote]

Updated

11 years ago
Duplicate of this bug: 368728

Updated

11 years ago
Duplicate of this bug: 372827

Comment 4

11 years ago
This bug continues to come up.  Can we fix it for 0.5?
Flags: blocking-calendar0.5?

Comment 5

11 years ago
I knew I had seen it before: bug 278302 which is a dupe of bug 257632 which was fixed by bug 297934. This ended in a regression-bug: bug 321164
(Assignee)

Comment 6

11 years ago
Created attachment 257533 [details] [diff] [review]
rev0 - use correct scope

this.mTasksInView is undefined. This means we will return to early from onModifyItem() for tasks. Some lines above/below we already use the correct scoped version this.calView.mTasksInView.
Assignee: nobody → ssitter
Status: NEW → ASSIGNED
Attachment #257533 - Flags: second-review?(jminta)
Attachment #257533 - Flags: first-review?(jminta)

Comment 7

11 years ago
Comment on attachment 257533 [details] [diff] [review]
rev0 - use correct scope

yep yep.
Attachment #257533 - Flags: second-review?(jminta)
Attachment #257533 - Flags: second-review+
Attachment #257533 - Flags: first-review?(jminta)
Attachment #257533 - Flags: first-review+
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Flags: blocking-calendar0.5? → blocking-calendar0.5+
Keywords: relnote
OS: Windows XP → All
Hardware: PC → All
Whiteboard: [cal relnote]
Target Milestone: --- → Sunbird 0.5
(Assignee)

Comment 9

11 years ago
Note: There is still an open issue when editing a task with only start or due date set to a task with both dates set. I filed Bug 372855 for this issue.
(Reporter)

Comment 10

11 years ago
task is not visible, I have to refresh to see it
-> Reopen

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a3pre) Gecko/20070308 Calendar/0.6a1
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 11

11 years ago
confirmed in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3pre) Gecko/20070310 Calendar/0.5pre

Error: aDate has no properties
Source File: file:///C:/Program%20Files/Calendar/js/calUtils.js
Line: 567
Whiteboard: [no l10n impact]
(Assignee)

Comment 12

11 years ago
I already filed Bug 372855 for the open issue as written in Comment #9, there was no need to reopen the bug.
Depends on: 372855
Marking FIXED per comment #12.
Status: REOPENED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → FIXED
VERIFIED with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4pre) Gecko/20070522 Calendar/0.5pre.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Flags: blocking-calendar0.5+
Whiteboard: [no l10n impact]
You need to log in before you can comment on or make changes to this bug.