Closed Bug 353497 Opened 14 years ago Closed 13 years ago

Options dialog for Lightning should be more easily discoverable.

Categories

(Calendar :: Lightning Only, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Lightning 0.5

People

(Reporter: cmtalbert, Assigned: jminta)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Thunderbird version 3 alpha 1 (20060919) and Lightning Build ID 2006091919 (my own build)

Most extensions with options allow the user to configure those options from the "Add-Ons" dialog page. However, extensions that install their options into the Tools->Options menu generally disable this button. 

Since most extensions at this time, do use their Add-Ons Options button, I think it would be far more discoverable and easier for the users if the Lighting Options button redirected the user to the Lightning Tab of the main tools->Options dialog.
At the very least, it could open the Tools->Options dialog for the user. Another alternative would be to overrride the Options button tooltip of the Add-On dialog for lightning that directs the user to look at the Tools->Options dialog instead.


Reproducible: Always

Steps to Reproduce:
1. Install Lightning
2. Try to check the Lightning options by going to the Add-On dialog and checking the option button.
3. Realize you can't and you need to go to Tools->Options to find it.


Actual Results:  
For new users, the mental leap required in step three can be a little daunting at first.

Expected Results:  
Make that mental leap as small as possible.

Leaving it at normal. The more tiny polish features like this that we can do to make the user experience better, the better off we'll be.
Attached patch add optionsURLSplinter Review
I still haven't fixed my lightning dev environment, so clint, if you could test and review, I'd appreciate it.  This patch specifies the normal TB options dialog as Lightning's options url too.
Assignee: nobody → jminta
Status: NEW → ASSIGNED
Attachment #248046 - Flags: second-review?(dmose)
Attachment #248046 - Flags: first-review?(ctalbert.moz)
Comment on attachment 248046 [details] [diff] [review]
add optionsURL

Looks good. I simply have one question. Is there a way via this RDF file to have the main preference window open to the Lightning tab when the user clicks on the "Options" button?  I believe this will bring up the Thunderbird options panel, which is OK, but if it could somehow default to the "Lightning" tab on that options panel, that would be excellent.

That said, I like this approach because it is simple and the user will easily find the Lightning tab from the main preference panel.
ctalbert r+
Attachment #248046 - Flags: first-review?(ctalbert.moz) → first-review+
Attachment #248046 - Flags: second-review?(dmose)
Comment on attachment 248046 [details] [diff] [review]
add optionsURL

I don't think we can easily do the "open to the Lightning tab" thing from install.rdf.

This doesn't work for testers using Ln-Fx, but since that's intended only for devs and is unsupported, I think it's okay.

r=lilmatt
Attachment #248046 - Flags: second-review+
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Target Milestone: --- → Lightning 0.5
You could also add a menu item for options to the Calendar menu on Thunderbird's main menu bar.  That might be the first place where some new users would look.
You need to log in before you can comment on or make changes to this bug.