All users were logged out of Bugzilla on October 13th, 2018

crypto.signText() does not work with OCSP certs

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
12 years ago
4 years ago

People

(Reporter: kaie, Unassigned)

Tracking

({regression})

1.8 Branch
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kerh-bra])

(Reporter)

Description

12 years ago
Own a personal certificate that lists an OCSP responder.
Enable OCSP.
Go to a web page that uses crypto.signText()
Attempt to sign using your cert.

Actual behaviour:
You get an error message, "internal failure, unable to complete OCSP operation".
The signing operation can not be completed

Expected behaviour:
No error message should be shown and signing should work.

This bug is similar to 337517, the cause is that the OCSP request is started
synchronously from the main thread, which is not supported.
(Reporter)

Updated

12 years ago
Keywords: regression
Whiteboard: [kerh-bra]
(Reporter)

Updated

12 years ago
Depends on: 337517
(Reporter)

Updated

12 years ago
No longer depends on: 337517
(Reporter)

Comment 1

12 years ago
A solution for the trunk is available in bug 353597.
I do not have a low risk solution for the stable 1.8 branch at this time.
Depends on: 353597
QA Contact: psm

Comment 2

9 years ago
This bug still exists in the latest stable version of thunderbird. The single solution I have is to clear certificate for encription.
(Reporter)

Comment 3

6 years ago
reassign bug owner.
mass-update-kaie-20120918
Assignee: kaie → nobody
Bug 1030963 removed this functionality entirely.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.