firefox crashes on certain png images used in the css cursor property

RESOLVED DUPLICATE of bug 353553

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 353553
12 years ago
12 years ago

People

(Reporter: Frederik Reiss, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

When i use the "cursor:url(...);" css property Firefox crashes on certain images used as cursor. The crash happens only in Windows XP SP2 but not under Linux (didn't test in OSX). And it also seems to depend on the size of the image used:

crash:
  32x16.png
  33x17.png
no crash:
  32x16.png
  33x15.png
  33x17.png


Reproducible: Sometimes

Steps to Reproduce:
1. save the html file as "test.html"
2. save one of the png file as "test.png" in the same directory as the html file
3. open the html file
4. click on the "test" link sometimes
Actual Results:  
firfox crashes sometimes

Expected Results:  
firfox should not crash

I tested this on some firefox versions:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.13) Gecko/20060410 Firefox/1.0.8
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/2006082101 Firefox/2.0b2
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/2006092004 Minefield/3.0a1

1.0.8 and 3.0a1 don't crash (and also don't display the cursor image).
1.5.0.7 an 2.0b2 display the cursor image crash.

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 353553 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.