"ASSERTION: bad caller" setting lquote on mstyle

RESOLVED WORKSFORME

Status

()

Core
MathML
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: Jesse Ruderman, Assigned: rbs)

Tracking

(Blocks: 1 bug, {assertion, testcase})

Trunk
PowerPC
Mac OS X
assertion, testcase
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

312 bytes, application/xhtml+xml
Details
(Reporter)

Description

12 years ago
This testcase triggers an assertion added by the patch in bug 347496:

###!!! ASSERTION: bad caller: 'aContent->Tag() == nsMathMLAtoms::mstyle_ || aContent->Tag() == nsMathMLAtoms::mtable_', file /Users/admin/trunk/mozilla/layout/mathml/base/src/nsMathMLFrame.cpp, line 90
(Reporter)

Comment 1

12 years ago
Created attachment 239480 [details]
testcase
(Reporter)

Comment 2

11 years ago
WFM on trunk; I no longer get the "bad caller" assertion.  I do get the assertion "dangling frame without a content node", though.  I'll file a new bug for that, since the testcase is simpler.  Once that bug is fixed, I'll try to get this testcase into a regression test suite too.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

11 years ago
Filed bug 400475.
(Reporter)

Comment 4

10 years ago
Crashtest checked in.
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.