Closed Bug 35369 Opened 25 years ago Closed 25 years ago

oversize table expanding BODY

Categories

(Core :: Layout: Tables, defect, P3)

x86
Linux
defect

Tracking

()

VERIFIED DUPLICATE of bug 35681

People

(Reporter: dbaron, Assigned: karnaze)

References

()

Details

DESCRIPTION:  Elements that are wider than their parents should not expand their
parents.  This seems to be happening right now on
http://www.w3.org/TR/css3-selectors .  This is a *major* problem since it
requires side-to-side scrolling for the entire document, rather than just the
one wide table.

STEPS TO REPRODUCE:
 * load http://www.w3.org/TR/css3-selectors
 * make your window reasonably narrow - narrow enough so that the table in the
beginning of section 2 is wider than the window.  (This is not unusually
narrow.)

ACTUAL RESULTS:
 * all the text in the document is reflowed so as to require side-to-side
scrolling.

EXPECTED RESULTS:
 * only the table should require side-to-side scrolling

DOES NOT WORK CORRECTLY ON:
 * Linux, mozilla, 2000-04-10-08-M15

ADDITIONAL INFORMATION:
This is probably a regression.  I really think I, and others, would have noticed
it much sooner if it weren't.
Chris, I'm assuming this is a table specific problem. Let me know if it isn't
Assignee: troy → karnaze
Component: Layout → HTMLTables
QA Contact: petersen → chrisd
Status: NEW → ASSIGNED
Target Milestone: --- → M17
This is not table-specific.  Marking duplicate of more general bug.

*** This bug has been marked as a duplicate of 35681 ***
Status: ASSIGNED → RESOLVED
Closed: 25 years ago
Resolution: --- → DUPLICATE
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.