Recurring all-day events are shown from 00:00 to 24:00 (allday)

VERIFIED FIXED in Sunbird 0.3

Status

Calendar
General
VERIFIED FIXED
12 years ago
12 years ago

People

(Reporter: Sebastian Schwieger, Assigned: Matthew (lilmatt) Willis)

Tracking

({regression})

Trunk
Sunbird 0.3
x86
Windows XP
regression

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
A recurring Allday event is treated as normal event (e.g. in day view it covers the whole view).

Works in 2006092106
Doesn't work in 2006092205

Steps to reproduce:
1. create recurring allday event (e.g. birthday)
2. switch to day view

result: events spans the whole day

this happens in Sunbird and Lightning (latest hourly)
(Reporter)

Updated

12 years ago
Flags: blocking0.3?

Comment 1

12 years ago
From reading the code, this ought to be a regression from bug 349788, which seems to fail to restore the isDate setting (in convertDate) on the dates it returns for occurrences.
Blocks: 349788
(Assignee)

Comment 2

12 years ago
Created attachment 239685 [details] [diff] [review]
rev0 - Ensures the end date used in ritem.getOccurrences is a datetime object

So this backs out most of the fix from bug 349788, and reimplements it differently.

Only changing aRangeEnd to be a datetime object appears to be enough to fix bug 349788 and prevent this bug from occurring.
Assignee: nobody → lilmatt
Status: NEW → ASSIGNED
Attachment #239685 - Flags: second-review?(dmose)
Attachment #239685 - Flags: first-review?(cmtalbert)
(Assignee)

Comment 3

12 years ago
*** Bug 353855 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

12 years ago
Flags: blocking0.3? → blocking0.3+
Summary: recurring allday events are screwed up → Recurring all-day events are shown from 00:00 to 24:00 (allday)
(Assignee)

Updated

12 years ago
Whiteboard: [patch in hand][needs review ctalbert dmose]

Comment 4

12 years ago
Comment on attachment 239685 [details] [diff] [review]
rev0 - Ensures the end date used in ritem.getOccurrences is a datetime object

R+ on this. We probably need to revert this change and make the permanent fix to the C++ layer in calIRecurrenceRule.
Attachment #239685 - Flags: first-review?(cmtalbert) → first-review+

Comment 5

12 years ago
Comment on attachment 239685 [details] [diff] [review]
rev0 - Ensures the end date used in ritem.getOccurrences is a datetime object

Looks good; the real fix is going to be in a spin off bug which I believe ctalbert is filing.
Attachment #239685 - Flags: second-review?(dmose) → second-review+
(Assignee)

Comment 6

12 years ago
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 7

12 years ago
verified with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060929 Sunbird/0.3
Status: RESOLVED → VERIFIED
Whiteboard: [patch in hand][needs review ctalbert dmose] → [patch in hand][needs review ctalbert dmose][litmus testcase wanted]
(Assignee)

Updated

12 years ago
Whiteboard: [patch in hand][needs review ctalbert dmose][litmus testcase wanted] → [litmus testcase wanted]

Updated

12 years ago
Whiteboard: [litmus testcase wanted]
You need to log in before you can comment on or make changes to this bug.