Closed Bug 35387 Opened 25 years ago Closed 25 years ago

popup menus are not selectable while button-3 is down on initial popup

Categories

(Core :: XUL, defect, P3)

Other
Linux
defect

Tracking

()

VERIFIED DUPLICATE of bug 16766

People

(Reporter: cks+mozilla, Assigned: mikepinkerton)

Details

(Keywords: platform-parity)

Build ID: 2000041008, but this has apparently been the behavior for some
time.

 The traditional way for popup menus to behave in X11 applications
and how the popup menus behave in Netscape 4.72 is that a popup menu
is posted on button-3 down and remains up only so long as you hold button
3 down. You select items by moving the mouse cursor over them while
holding button-3 down, which visually marks them as the currently
selected item, and finalize your selection by releasing button-3 while
the item you want is selected. If you release button-3 while the mouse
cursor is outside the menu, nothing is selected.

 Mozilla popup menus don't behave like this. They have two main states:
selections by moving the mouse over items aren't possible and selections
are possible. On initial popup you can't select anything, and releasing
button-3 will leave the menu up and suddenly selectable. There are a
number of other whacky ways to get into a selection-OK state (button-2
on an item, button-1 and then move around, and probably more), some of
which will leave the menu posted after you release button 3 and some of
which won't (button-1 press & release will immediately pop the menu
down, selection made!).

 I suspect/hope/believe that this behavior is somewhere between a bug
and a misfeature, and should be corrected to be the 'traditional' X,
GTK, and Netscape behavior described in the first paragraph.

 If nothing else, users moving from Netscape 4 will be surprised by
the current popup behavior. For a while I thought popup menus were
broken (!).
interesting...
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: 4xp, pp
Hardware: PC → Other


*** This bug has been marked as a duplicate of 16766 ***
Status: NEW → RESOLVED
Closed: 25 years ago
Resolution: --- → DUPLICATE
verif.
Status: RESOLVED → VERIFIED
*** Bug 207012 has been marked as a duplicate of this bug. ***
Oops, sorry duped 207012 to the wrong bug
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: bugzilla → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.