Last Comment Bug 353983 - --enable-application=netwerk (standalone necko)
: --enable-application=netwerk (standalone necko)
Status: RESOLVED FIXED
: dev-doc-complete
Product: Core
Classification: Components
Component: Networking (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla1.9alpha1
Assigned To: Christian :Biesinger (don't email me, ping me on IRC)
:
Mentors:
Depends on: 354835
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-23 12:44 PDT by Christian :Biesinger (don't email me, ping me on IRC)
Modified: 2009-02-18 14:34 PST (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (10.14 KB, patch)
2006-09-23 12:45 PDT, Christian :Biesinger (don't email me, ping me on IRC)
no flags Details | Diff | Review
patch v2 (18.00 KB, patch)
2006-09-23 18:52 PDT, Christian :Biesinger (don't email me, ping me on IRC)
no flags Details | Diff | Review
patch v3 (18.00 KB, patch)
2006-09-23 19:01 PDT, Christian :Biesinger (don't email me, ping me on IRC)
benjamin: review+
darin.moz: superreview+
Details | Diff | Review

Description Christian :Biesinger (don't email me, ping me on IRC) 2006-09-23 12:44:03 PDT
To make it possible to build standalone Necko, I want to add an --enable-application=netwerk compile option. This builds just the libraries that Necko needs (essentially XPCOM, libpref, intl and necko itself).

This adds a tier_necko which contains parts of tier_gecko.

NOTE: I had to name this netwerk rather than necko because the build system expects a mozilla/$(MOZ_BUILD_APP)/build.mk file. I could add a necko alias if desired.

Also, it is not really possible to run the unit tests here, because almost all of them need xpcshell and therefore xpconnect, which is not build in this configuration. Perhaps --enable-tests should build it.
Comment 1 Christian :Biesinger (don't email me, ping me on IRC) 2006-09-23 12:45:07 PDT
Created attachment 239812 [details] [diff] [review]
patch
Comment 2 Christian :Biesinger (don't email me, ping me on IRC) 2006-09-23 18:52:40 PDT
Created attachment 239849 [details] [diff] [review]
patch v2

Now with client.mk changes. Also, fixes the condition for the libreg build, this is the change:
-ifneq (,$(MOZ_NO_XPCOM_OBSOLETE)$(MOZ_XPINSTALL))
+ifneq (1_,$(MOZ_NO_XPCOM_OBSOLETE)_$(MOZ_XPINSTALL))

That should lead to the desired result of libreg being built if xpcom-obsolete is built or if xpinstall is built (or both)
Comment 3 Christian :Biesinger (don't email me, ping me on IRC) 2006-09-23 19:01:27 PDT
Created attachment 239850 [details] [diff] [review]
patch v3

oops. fix BOOTSTRAP variables. sorry for the bugspam...
Comment 4 Christian :Biesinger (don't email me, ping me on IRC) 2006-09-23 20:17:58 PDT
Comment on attachment 239850 [details] [diff] [review]
patch v3

+  mozilla/extensions/auth                       \

looks like this has to be removed, or normal checkouts will be broken :(
Comment 5 Darin Fisher 2006-09-24 13:48:30 PDT
Comment on attachment 239850 [details] [diff] [review]
patch v3

I'm fine with this provided bsmedberg is happy with the build details.
Comment 6 Christian :Biesinger (don't email me, ping me on IRC) 2006-09-28 14:28:43 PDT
checked in
Comment 7 Nickolay_Ponomarev 2008-01-17 12:12:13 PST
There's no documentation for this, right? Adding dev-doc-needed, as at the very least various outdated docs on MDC should be updated to say that standalone necko builds are possible.
Comment 8 Fernando Cassia 2009-01-13 12:05:15 PST
And so it transpires that Google decided to code their own networking implementation from scratch for use in its upcoming Chrome 2.0 browser.

Great work, Mozilla.org! (NOT!). You guys missed a great chance to have the Mozilla networking libs used by another major software player.

I guess nobody even thought of approaching Google to make them use Necko when they were having trouble porting Chrome to non-Windows platforms due to its reliance on WinHTTP, right?

Well, too late now...

FC
Comment 10 Ted Mielczarek [:ted.mielczarek] 2009-01-13 12:09:40 PST
You know that Darin Fisher (one of the lead engineers on Chrome) used to be the owner of our network module, right? I don't think this was due to lack of knowledge of the existence of necko.
Comment 11 Eric Shepherd [:sheppy] 2009-02-17 09:04:33 PST
So what would a .mozconfig file for this look like?  Just

ac_add_options --enable-application=netwerk

Or would more stuff be needed as well?  I'm working on documenting this at:

https://developer.mozilla.org/En/Building_Necko_standalone

Note You need to log in before you can comment on or make changes to this bug.