Closed Bug 353994 Opened 13 years ago Closed 13 years ago

[email_in] Make the email interface able to update (process) bugs

Categories

(Bugzilla :: Incoming Email, enhancement)

2.23
enhancement
Not set

Tracking

()

RESOLVED FIXED
Bugzilla 3.0

People

(Reporter: mkanat, Assigned: mkanat)

References

Details

Attachments

(1 file)

Okay, this is the next step of the inbound email interface--it should have the ability to update bugs, similar to process_bug.cgi.
Attached patch v1Splinter Review
Okay. This requires the other email_in patch, obviously.

I have tested this pretty well, and it works. The changes to process_bug are basically to avoid it ever having to output a template.

We don't have to worry about midairs, because it's impossible to midair with the email interface.
Assignee: general → mkanat
Status: NEW → ASSIGNED
Attachment #239827 - Flags: review?(colin.ogilvie)
Comment on attachment 239827 [details] [diff] [review]
v1

Looks good to me, tested it and it seems to work.

Again, I think at least reporting errors to the user about what has/has not worked would be nice though:

I tried @shortdesc but it's actually @short_desc and obviously nothing happened but I got no errors back again.

Locally I am getting the following:
DBI::db=HASH(0x9dcefd8)->disconnect invalidates 1 active statement handle (either destroy statement handles or call finish on them before disconnecting) at Bugzilla.pm line 392, <STDIN> line 28.

Note the DBI::db error at the bottom as seen in another bug (Bug 349210). This only occured after applying this patch, the original is fine :)

Requesting r? from ghendricks again.
Attachment #239827 - Flags: review?(ghendricks)
Attachment #239827 - Flags: review?(colin.ogilvie)
Attachment #239827 - Flags: review+
Comment on attachment 239827 [details] [diff] [review]
v1

It would be good if we include an example email message for both posting and updating a bug in the docs.
Attachment #239827 - Flags: review?(ghendricks) → review+
Flags: approval?
Flags: approval? → approval+
As far as the DBI::db error message goes, that's definitely a bug and we should look into it. It's probably a bug with this patch.

I agree, it would be nice to return some information about what was and wasn't processed--could you file a bug for that, Colin, and CC me?

I also agree that it would be nice to have another example there, for process_bug. ghendricks--could you file that and CC me?

Checking in email_in.pl;
/cvsroot/mozilla/webtools/bugzilla/email_in.pl,v  <--  email_in.pl
new revision: 1.2; previous revision: 1.1
done
Checking in process_bug.cgi;
/cvsroot/mozilla/webtools/bugzilla/process_bug.cgi,v  <--  process_bug.cgi
new revision: 1.344; previous revision: 1.343
done
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Component: Bugzilla-General → Incoming Email
Duplicate of this bug: 485909
You need to log in before you can comment on or make changes to this bug.